summaryrefslogtreecommitdiff
path: root/tests/lib-gdr
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lib-gdr')
-rw-r--r--tests/lib-gdr126
1 files changed, 106 insertions, 20 deletions
diff --git a/tests/lib-gdr b/tests/lib-gdr
index 479ef41..cda11df 100644
--- a/tests/lib-gdr
+++ b/tests/lib-gdr
@@ -3,6 +3,8 @@
: ${GDR_TEST_DEBUG=-D}
export GDR_TEST_DEBUG
+t-tstunt debchange
+
t-git-debrebase () {
local gdr=${DGIT_GITDEBREBASE_TEST-git-debrebase}
: '
@@ -21,22 +23,35 @@ t-gdr-good () {
# stitched
# pushed
- git diff --quiet ${beforetag-t.before} -- ':.' ':!debian/patches'
+ case $state in
+ pushed*)
+ t-gdr-made-patches
+ ;;
+ esac
- local etypes bwtip
+ git diff --quiet ${beforetag-t.before} -- ':.' ':!debian/patches'
LC_MESSAGES=C t-git-debrebase status >../status.check
case $state in
- laundered)
+ laundered*)
egrep '^ *branch is laundered' ../status.check
;;
- stitched|pushed)
+ stitched*|pushed*)
egrep \
'^ *branch contains furniture|^ *branch is unlaundered|^ *branch needs laundering' ../status.check
egrep '^ stitched$' ../status.check
;;
esac
+ t-gdr-good-analyse HEAD $state
+}
+
+t-gdr-good-analyse () {
+ local head=$1
+ local state=$2
+ local wsfx=$3
+ local etypes bwtip
+
# etypes is either a type,
# or PseudoMerge-<more etypes>
# or AddPatches-<more etypes>
@@ -49,11 +64,14 @@ t-gdr-good () {
stitched) etypes=Pseudomerge-Upstream ;;
pushed) etypes=AddPatches-Pseudomerge-Upstream ;;
pushed-interop) etypes=Pseudomerge-AddPatchesInterop-Upstream ;;
+ breakwater) etypes=Packaging ;;
+ *) fail-unknown-state-$state ;;
esac
- t-git-debrebase analyse >../anal.check
- expect=`git rev-parse HEAD`
- exec <../anal.check
+ anal=../anal$wsfx
+ t-git-debrebase analyse $head >$anal.check
+ expect=`git rev-parse $head`
+ exec <$anal.check
local cid ctype info nparents
while read cid ctype info; do
: ===== $cid $ctype $info =====
@@ -69,6 +87,8 @@ t-gdr-good () {
Pseudomerge/SAME) ;;
Packaging/SAME) ;;
Packaging/Upstream) ;;
+ MergedBreakwaters/Packaging) ;;
+ MergedBreakwaters/Upstream) ;;
AddPatches/SAME) ;;
AddPatches/AddPatchesInterop) ;;
Changelog/Packaging) ;;
@@ -108,9 +128,9 @@ t-gdr-good () {
: 'reject pointless pseudomerges'
local overwritten=${parents/$expect/}
overwritten=${overwritten// /}
- t-git-debrebase analyse $overwritten >../anal.overwr
+ t-git-debrebase analyse $overwritten >$anal.overwr
local ocid otype oinfo
- read <../anal.overwr ocid otype oinfo
+ read <$anal.overwr ocid otype oinfo
case "$otype" in
Pseudomerge) test "x$info" != "x$oinfo" ;;
esac
@@ -133,6 +153,9 @@ t-gdr-good () {
Upstream/SAME)
git diff --quiet $expect..$cid -- ':debian'
;;
+ MergedBreakwaters)
+ enparents=2
+ ;;
Anchor)
break
;;
@@ -151,37 +174,52 @@ t-gdr-good () {
*) fail 'unexpected parent' ;;
esac
+ case "$ctype" in
+ MergedBreakwaters)
+ local f
+ local parent_ix=0
+ for f in $parents; do
+ t-gdr-good-analyse $f breakwater \
+ $wsfx-mp$parent_ix
+ parent_ix=$(( $parent_ix + 1 ))
+ done
+ return
+ ;;
+ esac
+
done
}
t-some-changes () {
local token=$1
- local which=${2-dum}
+ local which=${2:-dum}
+ local fsuffix=$3
t-git-next-date
case "$which" in
*d*)
- echo >>debian/zorkmid "// debian $token"
- git add debian/zorkmid
- git commit -m "DEBIAN add zorkmid ($token)"
+ echo >>debian/zorkmid$fsuffix "// debian $token"
+ git add debian/zorkmid$fsuffix
+ git commit -m "DEBIAN add zorkmid$fsuffix ($token)"
;;
esac
case "$which" in
*u*)
- echo >>src.c "// upstream $token"
- git commit -a -m "UPSTREAM edit src.c ($token)"
+ echo >>src$fsuffix.c "// upstream $token"
+ git add src$fsuffix.c
+ git commit -m "UPSTREAM edit src$fsuffix.c ($token)"
;;
esac
case "$which" in
*m*)
- for f in debian/zorkmid src.c; do
+ for f in debian/zorkmid$fsuffix src$fsuffix.c; do
echo "// both! $token" >>$f
git add $f
done
- git commit -m "MIXED add both ($token)"
+ git commit -m "MIXED add both($fsuffix) ($token)"
;;
esac
@@ -191,11 +229,9 @@ t-some-changes () {
t-make-new-upstream-tarball () {
local uv=$1
git checkout make-upstream
- # leaves ust set to filename of orig tarball
echo "upstream $uv" >>docs/README
git commit -a -m "upstream $uv tarball"
- ust=example_$uv.orig.tar.gz
- git archive -o ../$ust --prefix=example-2.0/ make-upstream
+ t-make-orig example $uv make-upstream
}
t-nmu-upload-1 () {
@@ -289,3 +325,53 @@ t-nmu-reconciled-good () {
git checkout master
t-dgit -wgf quilt-fixup
}
+
+t-gdr-prep-new-upstream () {
+ uv=$1
+ t-git-next-date
+ git checkout make-upstream
+ git reset --hard upstream
+ t-make-new-upstream-tarball $uv
+ git push . make-upstream:upstream
+ git checkout master
+ t-git-next-date
+}
+
+t-gdr-gbp-import-core () {
+ p=example
+ t-worktree 1.1
+
+ cd example
+
+ : 'fake up some kind of upstream'
+ git checkout -b upstream quilt-tip
+ rm -rf debian
+ mkdir debian
+ echo junk >debian/rules
+ git add debian
+ git commit -m "an upstream retcon ($0)"
+ git tag v1.0
+}
+
+t-gdr-gbp-import-core-with-queue () {
+ t-gdr-gbp-import-core
+
+ : 'fake up that our quilt-tip was descended from upstream'
+ git checkout quilt-tip
+ git merge --no-edit -s ours upstream
+
+ : 'fake up that our quilt-tip had the patch queue in it'
+ git checkout patch-queue/quilt-tip
+ gbp pq export
+ git add debian/patches
+ git commit -m "patch queue update ($0)"
+
+ : 'make branch names more conventional'
+ git branch -D master
+ git branch -m quilt-tip master
+}
+
+t-gdr-made-patches () {
+ git log -n1 --'pretty=format:%B' \
+ | egrep '^\[git-debrebase'
+}