summaryrefslogtreecommitdiff
path: root/tests/lib-import-chk
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lib-import-chk')
-rw-r--r--tests/lib-import-chk13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/lib-import-chk b/tests/lib-import-chk
index ee33cbe..88984c1 100644
--- a/tests/lib-import-chk
+++ b/tests/lib-import-chk
@@ -1,4 +1,15 @@
+t-import-chk-authorship () {
+ perl -ne 'print $1,"\n" if m/^ -- (\S.*\>) /' debian/changelog \
+ | sort -u \
+ > $tmp/authorship.changelog
+ ${import_chk_changelog_massage:-:} $tmp/authorship.changelog
+ git log --pretty=format:'%an <%ae>%n%cn <%ce>' \
+ | sort -u \
+ > $tmp/authorship.commits
+ diff $tmp/authorship.{changelog,commits}
+}
+
t-import-chk1 () {
p=$1
v=$2
@@ -15,6 +26,8 @@ t-import-chk2() {
cd $p
+ t-import-chk-authorship
+
git branch first-import
m='Commit for import check'