summaryrefslogtreecommitdiff
path: root/tests/lib
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lib')
-rw-r--r--tests/lib21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/lib b/tests/lib
index 4ef275c..99345ce 100644
--- a/tests/lib
+++ b/tests/lib
@@ -17,6 +17,8 @@ funcs: ${FUNCNAME[*]}
lines: ${BASH_LINENO[*]}
files: ${BASH_SOURCE[*]}
END
+ t-save-artifacts
+
exit 16
}
@@ -409,9 +411,18 @@ t-fscks () {
t-ok () {
: '========================================'
t-fscks
+ t-save-artifacts
echo ok.
}
+t-save-artifacts () {
+ artifacts="$AUTOPKGTEST_ARTIFACTS"
+ if [ x"$artifacts" = x ]; then return; fi
+ if [ x"tmp" = x ]; then return; fi
+ GZIP=-1v tar -C "$tmp" -zc -f "$artifacts/${0##*/}.tar.gz" \
+ --exclude=\*.tar .
+}
+
t-rm-dput-dropping () {
rm -f $tmp/${p}_${v}_*.upload
}
@@ -1006,6 +1017,16 @@ t-commit () {
revision=$(( ${revision-0} + 1 ))
}
+t-dch-r-rune () {
+ local cmd="$1"; shift
+ local suite=${1-unstable}
+ $cmd -r -D "$suite" ''
+}
+
+t-dch-commit-r () {
+ t-dch-r-rune t-dch-commit "$@"
+}
+
t-dch-commit () {
faketime @"${GIT_AUTHOR_DATE% *}" dch "$@"
git commit -m "dch $*" debian/changelog