summaryrefslogtreecommitdiff
path: root/tests/lib
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lib')
-rw-r--r--tests/lib43
1 files changed, 37 insertions, 6 deletions
diff --git a/tests/lib b/tests/lib
index 6028133..57b9e38 100644
--- a/tests/lib
+++ b/tests/lib
@@ -33,8 +33,8 @@ export DGIT_TEST_DEBUG
: ${DGIT_TEST_DISTRO+ ${distro=${DGIT_TEST_DISTRO}}}
-export GIT_COMMITTER_DATE='1515000000 +0100'
-export GIT_AUTHOR_DATE='1515000000 +0100'
+export GIT_COMMITTER_DATE='1530000000 +0100'
+export GIT_AUTHOR_DATE='1530000000 +0100'
root=`pwd`
troot=$root/tests
@@ -62,10 +62,11 @@ t-set-using-tmp
test -f $tmp/.save-env || \
env -0 >$tmp/.save-env
-ln -f $troot/ssh ssh
+ln -sf $troot/ssh ssh
export DEBCHANGE_VENDOR=dpkg
unset VISUAL
+unset GIT_EDITOR
mkdir -p $tmp/incoming
cat <<END >$tmp/dput.cf
@@ -341,7 +342,7 @@ t-archive () {
v=$2
local dscf=${p}_$2.dsc
rm -f $tmp/mirror/pool/main/${p}_*
- ln $troot/pkg-srcs/${p}_${2%-*}* $tmp/mirror/pool/main/
+ ln -s $troot/pkg-srcs/${p}_${2%-*}* $tmp/mirror/pool/main/
t-archive-query $suite
rm -rf $tmp/extract
mkdir $tmp/extract
@@ -403,6 +404,13 @@ t-git-fsck () {
esac
}
+t-check-only-bpd () {
+ if [ "$bpd" = .. ]; then return; fi
+ t-files-notexist \
+ ../*.{deb,changes,dsc,buildinfo} \
+ ../*.{tar,diff}.*
+}
+
t-fscks () {
(
shopt -s nullglob
@@ -415,6 +423,7 @@ t-fscks () {
t-ok () {
: '========================================'
+ t-check-only-bpd
t-fscks
t-save-artifacts
echo ok.
@@ -1025,10 +1034,32 @@ t-make-badcommit () {
t-expect-fsck-fail $badcommit
}
+t-make-orig () {
+ # leaves ust set to filename of orig tarball
+ local p=$1
+ local v=$2
+ local tag=${3-v$2}
+ ust=${p}_${v}.orig.tar.gz
+ GZIP=-1 git archive -o $bpd/$ust --prefix=${p}-${v}/ $tag
+}
+
+t-merge-conflicted-stripping-conflict-markers () {
+ local otherbranch=$1
+ local file=$2
+
+ t-expect-fail F:"Merge conflict in $file" \
+ git merge $otherbranch
+
+ perl -i~ -ne 'print unless m{^(?:\<\<\<|\>\>\>|===)}' "$file"
+ git add "$file"
+ git commit --no-edit
+}
+
t-commit () {
local msg=$1
v=${2:-${majorv:-1}.$revision}
- dch --force-distribution -v$v --distribution ${3:-unstable} "$1"
+ $troot/tstunt/debchange \
+ --force-distribution -v$v --distribution ${3:-unstable} "$1"
git add debian/changelog
debcommit
revision=$(( ${revision-0} + 1 ))
@@ -1045,7 +1076,7 @@ t-dch-commit-r () {
}
t-dch-commit () {
- faketime @"${GIT_AUTHOR_DATE% *}" dch "$@"
+ $troot/tstunt/debchange "$@"
git commit -m "dch $*" debian/changelog
}