summaryrefslogtreecommitdiff
path: root/tests/lib
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lib')
-rw-r--r--tests/lib5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/lib b/tests/lib
index 24ccf7e..376585c 100644
--- a/tests/lib
+++ b/tests/lib
@@ -1041,7 +1041,8 @@ t-merge-conflicted-stripping-conflict-markers () {
t-commit () {
local msg=$1
v=${2:-${majorv:-1}.$revision}
- dch --force-distribution -v$v --distribution ${3:-unstable} "$1"
+ $troot/tstunt/debchange \
+ --force-distribution -v$v --distribution ${3:-unstable} "$1"
git add debian/changelog
debcommit
revision=$(( ${revision-0} + 1 ))
@@ -1058,7 +1059,7 @@ t-dch-commit-r () {
}
t-dch-commit () {
- faketime @"${GIT_AUTHOR_DATE% *}" dch "$@"
+ $troot/tstunt/debchange "$@"
git commit -m "dch $*" debian/changelog
}