summaryrefslogtreecommitdiff
path: root/tests/lib
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lib')
-rw-r--r--tests/lib8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/lib b/tests/lib
index 749509c..ee8d14f 100644
--- a/tests/lib
+++ b/tests/lib
@@ -1126,7 +1126,7 @@ t-merge-conflicted-stripping-conflict-markers () {
t-commit () {
local msg=$1
v=${2:-${majorv:-1}.$revision}
- $troot/tstunt/debchange \
+ t-debchange \
--force-distribution -v$v --distribution ${3:-unstable} "$1"
git add debian/changelog
debcommit
@@ -1144,10 +1144,14 @@ t-dch-commit-r () {
}
t-dch-commit () {
- $troot/tstunt/debchange "$@"
+ t-debchange "$@"
git commit -m "dch $*" debian/changelog
}
+t-debchange () {
+ DEBEMAIL=dgit-tests@example.org $troot/tstunt/debchange "$@"
+}
+
t-git-config () {
git config --global "$@"
}