summaryrefslogtreecommitdiff
path: root/tests/run-all
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-all')
-rwxr-xr-xtests/run-all20
1 files changed, 11 insertions, 9 deletions
diff --git a/tests/run-all b/tests/run-all
index e2e2a6f..f298cb7 100755
--- a/tests/run-all
+++ b/tests/run-all
@@ -1,13 +1,15 @@
#!/bin/sh
set -e
# convenience script for running the tests outside adt-run
-if [ $# = 0 ]; then
- set `run-parts --list tests/tests`
+# usage: tests/using-intree tests/run-all
+
+set +e
+jcpus=`perl -MSys::CPU -we 'printf "-j%d\n",Sys::CPU::cpu_count()'`
+set -e
+
+if [ $# != 0 ]; then
+ set TESTSCRIPTS="$*"
fi
-for f in $@; do
- echo ==================================================
- echo $f
- $f
- echo ==================================================
-done
-echo "ALL PASSED"
+
+set -x
+exec make $jcpus -f tests/Makefile "$@"