summaryrefslogtreecommitdiff
path: root/tests/run-all
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-all')
-rwxr-xr-xtests/run-all21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/run-all b/tests/run-all
new file mode 100755
index 0000000..e53b963
--- /dev/null
+++ b/tests/run-all
@@ -0,0 +1,21 @@
+#!/bin/bash
+set -e
+# convenience script for running the tests outside adt-run
+# usage: tests/using-intree tests/run-all
+
+set -o pipefail
+
+set +e
+jcpus=`perl -MSys::CPU -we 'printf "-j%d\n",Sys::CPU::cpu_count()'`
+set -e
+
+if [ $# != 0 ]; then
+ set TESTSCRIPTS="$*"
+fi
+
+mkdir -p tests/tmp
+
+(
+ set -x
+ exec make $jcpus -k -f tests/Makefile "$@"
+) 2>&1 |tee tests/tmp/run-all.log