summaryrefslogtreecommitdiff
path: root/tests/setup/gdr-convert-gbp
diff options
context:
space:
mode:
Diffstat (limited to 'tests/setup/gdr-convert-gbp')
-rwxr-xr-xtests/setup/gdr-convert-gbp27
1 files changed, 1 insertions, 26 deletions
diff --git a/tests/setup/gdr-convert-gbp b/tests/setup/gdr-convert-gbp
index b563c01..3b555e5 100755
--- a/tests/setup/gdr-convert-gbp
+++ b/tests/setup/gdr-convert-gbp
@@ -15,28 +15,7 @@ not-gdr-processable () {
t-git-debrebase analyse | grep 'Unknown Unprocessable'
}
-p=example
-t-worktree 1.1
-
-cd example
-
-: 'fake up some kind of upstream'
-git checkout -b upstream quilt-tip
-rm -rf debian
-mkdir debian
-echo junk >debian/rules
-git add debian
-git commit -m "an upstream retcon ($0)"
-
-: 'fake up that our quilt-tip was descended from upstream'
-git checkout quilt-tip
-git merge --no-edit -s ours upstream
-
-: 'fake up that our quilt-tip had the patch queue in it'
-git checkout patch-queue/quilt-tip
-gbp pq export
-git add debian/patches
-git commit -m "patch queue update ($0)"
+t-gdr-gbp-import-core
not-gdr-processable origin
@@ -44,10 +23,6 @@ not-gdr-processable origin
git branch make-upstream upstream
t-make-new-upstream-tarball 2.0
-: 'make branch names more conventional'
-git branch -D master
-git branch -m quilt-tip master
-
for b in \
quilt-tip-2 \
gitish-only \