summaryrefslogtreecommitdiff
path: root/tests/tests/push-source-with-changes
diff options
context:
space:
mode:
Diffstat (limited to 'tests/tests/push-source-with-changes')
-rwxr-xr-xtests/tests/push-source-with-changes14
1 files changed, 12 insertions, 2 deletions
diff --git a/tests/tests/push-source-with-changes b/tests/tests/push-source-with-changes
index 580ea3a..aed1b63 100755
--- a/tests/tests/push-source-with-changes
+++ b/tests/tests/push-source-with-changes
@@ -13,14 +13,24 @@ t-ref-head
# (1) try pushing a changes file containing binaries
-t-dgit --dpkg-buildpackage:-d build -F
+t-dgit build -F
t-expect-push-fail 'user-specified changes file is not source-only' \
t-dgit -C ../${p}_1.0_multi.changes push-source --new
# (2) try pushing a source-only changes file
-t-dgit --dpkg-buildpackage:-d build-source
+t-expect-fail F:'tree contains uncommitted files' \
+t-dgit build-source
+
+cp debian/rules{,~}
+git clean -df
+ls debian/rules~
+
+t-expect-fail F:'tree contains uncommitted files' \
+t-dgit -wdda build-source
+
+t-dgit build-source
t-dgit -C ../${p}_1.0_source.changes push-source --new
t-pushed-good master