summaryrefslogtreecommitdiff
path: root/tests/tests
diff options
context:
space:
mode:
Diffstat (limited to 'tests/tests')
-rwxr-xr-xtests/tests/build-modes-gbp1
-rwxr-xr-xtests/tests/oldnewtagalt2
-rwxr-xr-xtests/tests/push-source2
-rwxr-xr-xtests/tests/push-source-with-changes14
4 files changed, 15 insertions, 4 deletions
diff --git a/tests/tests/build-modes-gbp b/tests/tests/build-modes-gbp
index d99b791..93d0811 100755
--- a/tests/tests/build-modes-gbp
+++ b/tests/tests/build-modes-gbp
@@ -21,6 +21,7 @@ quirk-clean-fixup () {
}
bm_quirk_before_diff=quirk-clean-fixup
+cleanmodes_dpkgsource_extra=,no-check
bm-prep
for act in \
diff --git a/tests/tests/oldnewtagalt b/tests/tests/oldnewtagalt
index 098fe19..6730918 100755
--- a/tests/tests/oldnewtagalt
+++ b/tests/tests/oldnewtagalt
@@ -9,7 +9,7 @@ cd $p
test-push () {
t-commit "$1"
- t-dgit build-source
+ t-dgit -wgf build-source
t-dgit push
}
diff --git a/tests/tests/push-source b/tests/tests/push-source
index f0eafb8..79c4636 100755
--- a/tests/tests/push-source
+++ b/tests/tests/push-source
@@ -12,7 +12,7 @@ cd $p
t-refs-same-start
t-ref-head
-t-dgit --dpkg-buildpackage:-d push-source --new
+t-dgit push-source --new
t-pushed-good master
t-push-was-source-only
diff --git a/tests/tests/push-source-with-changes b/tests/tests/push-source-with-changes
index 580ea3a..aed1b63 100755
--- a/tests/tests/push-source-with-changes
+++ b/tests/tests/push-source-with-changes
@@ -13,14 +13,24 @@ t-ref-head
# (1) try pushing a changes file containing binaries
-t-dgit --dpkg-buildpackage:-d build -F
+t-dgit build -F
t-expect-push-fail 'user-specified changes file is not source-only' \
t-dgit -C ../${p}_1.0_multi.changes push-source --new
# (2) try pushing a source-only changes file
-t-dgit --dpkg-buildpackage:-d build-source
+t-expect-fail F:'tree contains uncommitted files' \
+t-dgit build-source
+
+cp debian/rules{,~}
+git clean -df
+ls debian/rules~
+
+t-expect-fail F:'tree contains uncommitted files' \
+t-dgit -wdda build-source
+
+t-dgit build-source
t-dgit -C ../${p}_1.0_source.changes push-source --new
t-pushed-good master