summaryrefslogtreecommitdiff
path: root/tests/tstunt/dpkg-parsechangelog
diff options
context:
space:
mode:
Diffstat (limited to 'tests/tstunt/dpkg-parsechangelog')
-rwxr-xr-xtests/tstunt/dpkg-parsechangelog8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/tstunt/dpkg-parsechangelog b/tests/tstunt/dpkg-parsechangelog
index 2e0360d..c45b124 100755
--- a/tests/tstunt/dpkg-parsechangelog
+++ b/tests/tstunt/dpkg-parsechangelog
@@ -14,10 +14,16 @@
# sys 0m0.012s
# $
+my $infile = "debian/changelog";
+
+if (@ARGV && $ARGV[0] =~ s/^-l//) {
+ $infile = shift @ARGV;
+}
+
die if @ARGV;
use strict;
-open C, "debian/changelog" or die $!;
+open C, $infile or die $!;
$!=0; $_ = <C>;
m/^(\S+) \(([^()]+)\) (\S+)\; urgency=(\S+)$/ or die "$!, $_ ?";