summaryrefslogtreecommitdiff
path: root/tests/tstunt/dpkg-parsechangelog
diff options
context:
space:
mode:
Diffstat (limited to 'tests/tstunt/dpkg-parsechangelog')
-rwxr-xr-xtests/tstunt/dpkg-parsechangelog2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/tstunt/dpkg-parsechangelog b/tests/tstunt/dpkg-parsechangelog
index c45b124..f1e75a8 100755
--- a/tests/tstunt/dpkg-parsechangelog
+++ b/tests/tstunt/dpkg-parsechangelog
@@ -14,6 +14,8 @@
# sys 0m0.012s
# $
+$SIG{__WARN__} = sub { die $_[0]; }; # no use of system, so we avoid #793471
+
my $infile = "debian/changelog";
if (@ARGV && $ARGV[0] =~ s/^-l//) {