summaryrefslogtreecommitdiff
path: root/tests/tstunt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/tstunt')
-rw-r--r--tests/tstunt/Dpkg/Changelog/Parse.pm3
-rwxr-xr-xtests/tstunt/dpkg-parsechangelog2
2 files changed, 5 insertions, 0 deletions
diff --git a/tests/tstunt/Dpkg/Changelog/Parse.pm b/tests/tstunt/Dpkg/Changelog/Parse.pm
index 89b5e57..d69b7df 100644
--- a/tests/tstunt/Dpkg/Changelog/Parse.pm
+++ b/tests/tstunt/Dpkg/Changelog/Parse.pm
@@ -60,6 +60,9 @@ sub changelog_parse {
my $fields = Dpkg::Control::Changelog->new();
$fields->parse(\*P, "output of stunt changelog parser");
+#use Data::Dumper;
+#print STDERR "PARSE $0 ", Dumper($fields);
+
close P or die "$! $?";
return $fields;
diff --git a/tests/tstunt/dpkg-parsechangelog b/tests/tstunt/dpkg-parsechangelog
index ba6ef54..6a9198a 100755
--- a/tests/tstunt/dpkg-parsechangelog
+++ b/tests/tstunt/dpkg-parsechangelog
@@ -18,6 +18,8 @@ $SIG{__WARN__} = sub { die $_[0]; }; # no use of system, so we avoid #793471
my $infile = "debian/changelog";
+#print STDERR ">@ARGV<\n";
+
my @orgargv = @ARGV;
if (@ARGV && $ARGV[0] =~ s/^-l//) {