summaryrefslogtreecommitdiff
path: root/tests/tstunt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/tstunt')
-rw-r--r--tests/tstunt/Dpkg/Changelog/Parse.pm17
1 files changed, 16 insertions, 1 deletions
diff --git a/tests/tstunt/Dpkg/Changelog/Parse.pm b/tests/tstunt/Dpkg/Changelog/Parse.pm
index 677580b..32be2dd 100644
--- a/tests/tstunt/Dpkg/Changelog/Parse.pm
+++ b/tests/tstunt/Dpkg/Changelog/Parse.pm
@@ -36,7 +36,22 @@ our @EXPORT = qw(changelog_parse);
die +(join " ", %ENV)." ?" if $ENV{'DGIT_NO_TSTUNT_CLPARSE'};
sub changelog_parse {
- my (%options) = @_; # ignored
+ my (%options) = @_; # largely ignored
+
+#use Data::Dumper;
+#print STDERR "CLOG PARSE ", Dumper(\%options);
+#
+# We can't do this because lots of things use `since' which
+# we don't implement, and it's the test cases that arrange that
+# the since value happens to be such that we are to print one output.
+#
+# foreach my $k (keys %options) {
+# my $v = $options{$k};
+# if ($k eq 'file') { }
+# elsif ($k eq 'offset') { die "$v ?" unless $v <= 1; } # wtf, 1==0 ?
+# elsif ($k eq 'count') { die "$v ?" unless $v == 1; }
+# else { die "$k ?"; }
+# }
$options{'file'} //= 'debian/changelog';