summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
Diffstat (limited to 'tests')
-rw-r--r--tests/Makefile14
-rwxr-xr-xtests/run-all20
2 files changed, 25 insertions, 9 deletions
diff --git a/tests/Makefile b/tests/Makefile
new file mode 100644
index 0000000..011bd3c
--- /dev/null
+++ b/tests/Makefile
@@ -0,0 +1,14 @@
+# usage: tests/using-intree make -f tests/Makefile
+# (optionally setting TESTSCRIPTS='tests/tests/foo tests/tests/bar')
+
+TESTSCRIPTS ?= $(shell run-parts --list tests/tests)
+TESTNAMES := $(notdir $(TESTSCRIPTS))
+
+all: $(foreach t,$(TESTNAMES),tests/tmp/$t.ok)
+ @echo "ALL PASSED"
+
+tests/tmp:
+ mkdir -p $@
+
+tests/tmp/%.ok: tests/tmp
+ tests/tests/$* >tests/tmp/$*.log 2>&1
diff --git a/tests/run-all b/tests/run-all
index e2e2a6f..f298cb7 100755
--- a/tests/run-all
+++ b/tests/run-all
@@ -1,13 +1,15 @@
#!/bin/sh
set -e
# convenience script for running the tests outside adt-run
-if [ $# = 0 ]; then
- set `run-parts --list tests/tests`
+# usage: tests/using-intree tests/run-all
+
+set +e
+jcpus=`perl -MSys::CPU -we 'printf "-j%d\n",Sys::CPU::cpu_count()'`
+set -e
+
+if [ $# != 0 ]; then
+ set TESTSCRIPTS="$*"
fi
-for f in $@; do
- echo ==================================================
- echo $f
- $f
- echo ==================================================
-done
-echo "ALL PASSED"
+
+set -x
+exec make $jcpus -f tests/Makefile "$@"