summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
Diffstat (limited to 'tests')
-rw-r--r--tests/lib10
-rw-r--r--tests/lib-gdr2
-rwxr-xr-xtests/setup/gdr-convert-gbp4
-rwxr-xr-xtests/tests/gdr-diverge-nmu-dgit2
-rwxr-xr-xtests/tests/gdr-edits2
-rwxr-xr-xtests/tests/gdr-import-dgit2
6 files changed, 16 insertions, 6 deletions
diff --git a/tests/lib b/tests/lib
index 4ef275c..04d1f2d 100644
--- a/tests/lib
+++ b/tests/lib
@@ -1006,6 +1006,16 @@ t-commit () {
revision=$(( ${revision-0} + 1 ))
}
+t-dch-r-rune () {
+ local cmd="$1"; shift
+ local suite=${1-unstable}
+ $cmd -r sid
+}
+
+t-dch-commit-r () {
+ t-dch-r-rune t-dch-commit "$@"
+}
+
t-dch-commit () {
faketime @"${GIT_AUTHOR_DATE% *}" dch "$@"
git commit -m "dch $*" debian/changelog
diff --git a/tests/lib-gdr b/tests/lib-gdr
index 22ea6d1..95d2330 100644
--- a/tests/lib-gdr
+++ b/tests/lib-gdr
@@ -222,7 +222,7 @@ t-nmu-upload-2 () {
}
t-nmu-upload-3 () {
- t-dch-commit -r sid
+ t-dch-commit-r
t-dgit -wgf build-source
diff --git a/tests/setup/gdr-convert-gbp b/tests/setup/gdr-convert-gbp
index 8049d87..d64b867 100755
--- a/tests/setup/gdr-convert-gbp
+++ b/tests/setup/gdr-convert-gbp
@@ -64,7 +64,7 @@ gbp import-orig --upstream-version=2.0 ../$ust
not-gdr-processable
t-dch-commit -v 2.0-1 -m 'new upstream (did gbp import-orig)'
-t-dch-commit -r sid
+t-dch-commit-r
$ifarchive t-archive-none $p
$ifarchive t-git-none
@@ -84,7 +84,7 @@ t-git-debrebase -fupstream-has-debian convert-from-gbp
v=2.0-2
t-dch-commit -v $v -m 'switch to git-debrebase, no other changes'
-t-dch-commit -r sid
+t-dch-commit-r
$ifarchive t-dgit -wgf push-source --new
git push
diff --git a/tests/tests/gdr-diverge-nmu-dgit b/tests/tests/gdr-diverge-nmu-dgit
index 4b5907a..1d136a9 100755
--- a/tests/tests/gdr-diverge-nmu-dgit
+++ b/tests/tests/gdr-diverge-nmu-dgit
@@ -28,7 +28,7 @@ t-git-next-date
v=2.0-2+nmu1
t-nmu-commit-an-upstream-change
t-dch-commit -v$v -m finalise
-t-dch-commit -r sid
+t-dch-commit-r
t-dgit -wgf push-source
diff --git a/tests/tests/gdr-edits b/tests/tests/gdr-edits
index 6c77184..52c083b 100755
--- a/tests/tests/gdr-edits
+++ b/tests/tests/gdr-edits
@@ -16,7 +16,7 @@ cat ../anal.1
t-some-changes edits
-t-dch-commit -r sid
+t-dch-commit-r
git tag t.before
diff --git a/tests/tests/gdr-import-dgit b/tests/tests/gdr-import-dgit
index 19918d8..c18c097 100755
--- a/tests/tests/gdr-import-dgit
+++ b/tests/tests/gdr-import-dgit
@@ -40,7 +40,7 @@ nmu-fold
v=2.0-3
t-dch-commit -v $v -m "incorporate nmu"
-t-dch-commit -r sid
+t-dch-commit-r
t-dgit -wgf push-source
: 'now test a new upstream'