summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-09-06 20:35:03 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-09-06 20:35:03 -0700
commit295de0d28f09f1b7052fb7284176a8478fa62b3d (patch)
tree88c561ee98bf842bb48ae8f6b9d2e5851d7f432e
parent9911e2cf4cc44264099ba8cca4c93ad5f21bcdb6 (diff)
fix version comparison in elpa.pm
The string representation of 0.90 is "0.9" which is a lower version than 0.77 (the version in jessie which the comparison is meant to exclude).
-rw-r--r--debian/changelog7
-rwxr-xr-xelpa.pm2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 559ee4f..cd66dab 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+dh-elpa (1.3) UNRELEASED; urgency=medium
+
+ * Fix version comparison in elpa.pm.
+ Quote "0.90" so that the trailing 0 is not lost.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Tue, 06 Sep 2016 20:33:13 -0700
+
dh-elpa (1.2) unstable; urgency=medium
* Add generated files to debian/clean:
diff --git a/elpa.pm b/elpa.pm
index d6e3126..a43f395 100755
--- a/elpa.pm
+++ b/elpa.pm
@@ -18,7 +18,7 @@ my $options;
$options = Config::Tiny->read( "debian/elpa-test" )
if ( -f "debian/elpa-test" );
-if ( $version >= 0.90
+if ( $version >= "0.90"
&& !defined $options->{_}->{ "disable" }
&& !defined $ENV{ 'DH_ELPA_TEST_DISABLE' }
) {