summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-04-10 10:08:52 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-04-10 10:08:52 -0700
commit856c012f99043d304f07693794dbca7a471e3dbf (patch)
tree3e6e89e6ffae694941d41f2162e4861d5566af21
parent8b3769a8cbc12b2cafb6dcde73549fdcef857af1 (diff)
use an environment variable to disable testing
-rw-r--r--debian/install1
-rwxr-xr-xdh_elpa.in12
-rwxr-xr-xdh_elpa_test4
-rwxr-xr-x[-rw-r--r--]elpa.pm6
-rwxr-xr-xelpa_plus_test.pm13
5 files changed, 15 insertions, 21 deletions
diff --git a/debian/install b/debian/install
index b760d68..c410d21 100644
--- a/debian/install
+++ b/debian/install
@@ -1,4 +1,3 @@
elpa.pm usr/share/perl5/Debian/Debhelper/Sequence
-elpa_plus_test.pm usr/share/perl5/Debian/Debhelper/Sequence
emacsen-common usr/share/debhelper/dh_elpa
usr/bin
diff --git a/dh_elpa.in b/dh_elpa.in
index cbf5823..f9e86cf 100755
--- a/dh_elpa.in
+++ b/dh_elpa.in
@@ -23,6 +23,11 @@ B<dh_elpa> [S<I<debhelper options>>] [S<I<pkg-file>>]
B<dh_elpa> is a debhelper program that is responsible for installing
elpa style emacs lisp packages into package build directories.
+B<dh_elpa> will attempt to run ERT and Buttercup test suites using
+dh_elpa_test(1). To disable this behaviour, or tweak it if it is
+failing to run the tests as they should be run, set environment
+variables in debian/rules as detailed in dh_elpa_test(1).
+
=head1 FILES
=over 4
@@ -314,10 +319,3 @@ substvars
=back
-=head1 SEE ALSO
-
-You can use B<dh_elpa_test> to run ERT and Buttercup test suites
-automatically. See dh_elpa_test(1).
-
-=cut
-
diff --git a/dh_elpa_test b/dh_elpa_test
index 5602caf..62bbf17 100755
--- a/dh_elpa_test
+++ b/dh_elpa_test
@@ -37,6 +37,10 @@ variable values with double-quotation marks. E.g.
=over 4
+=item B<DH_ELPA_TEST_DISABLE>
+
+If this variable is set, dh_elpa(1) will not invoke B<dh_elpa_test>.
+
=item B<DH_ELPA_TEST_BUTTERCUP_LOAD_PATH>
A comma-separated list of directories to add to the load-path when
diff --git a/elpa.pm b/elpa.pm
index cf73b54..dc64e33 100644..100755
--- a/elpa.pm
+++ b/elpa.pm
@@ -7,4 +7,10 @@ use Debian::Debhelper::Dh_Lib;
insert_after("dh_install", "dh_elpa");
+unless ( defined $ENV{ 'DH_ELPA_TEST_DISABLE' } ) {
+ # insert_after("dh_auto_test", "dh_elpa_test"); # test suite gets run more than once
+ add_command("dh_elpa_test", "build");
+ remove_command("dh_auto_test");
+}
+
1;
diff --git a/elpa_plus_test.pm b/elpa_plus_test.pm
deleted file mode 100755
index f56d60d..0000000
--- a/elpa_plus_test.pm
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/usr/bin/perl
-# debhelper sequence file for dh_elpa_test script
-
-use warnings;
-use strict;
-use Debian::Debhelper::Dh_Lib;
-
-insert_after("dh_install", "dh_elpa");
-# insert_after("dh_auto_test", "dh_elpa_test"); # test suite gets run more than once
-add_command("dh_elpa_test", "build");
-remove_command("dh_auto_test");
-
-1;