summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2017-01-19 15:37:19 -0700
committerSean Whitton <spwhitton@spwhitton.name>2017-01-19 15:37:19 -0700
commit93b8fd46eba4711e2735e15dbe00859af51ce00d (patch)
tree64b604c16e27430f9f8316b82f0236dc6bee2289
parent9b2dced21adf738a10aa02edf34b4ce272d8f987 (diff)
parente26a74596105f702ba7fcbe15bdf41f59b75555f (diff)
Merge tag 'debian/1.6' into jessie-bpo
uploaded to unstable
-rw-r--r--debian/changelog28
-rw-r--r--debian/control4
-rw-r--r--dh-elpa.el23
-rwxr-xr-xdh_elpa_test14
-rwxr-xr-xemacsen-common/remove3
5 files changed, 63 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index ed2b292..074d684 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,31 @@
+dh-elpa (1.6) unstable; urgency=medium
+
+ * Add an "exit 0" to xemacs case of remove script (Closes: #850036).
+
+ -- David Bremner <bremner@debian.org> Sun, 08 Jan 2017 09:28:52 -0400
+
+dh-elpa (1.5) unstable; urgency=high
+
+ * Add built-in packages to ${elpa:Depends} if they are also packaged
+ separately in Debian (e.g. let-alist and seq).
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Sun, 01 Jan 2017 21:16:24 +0000
+
+dh-elpa (1.4) unstable; urgency=medium
+
+ * Add note to dh_elpa_test manpage about disabling its override of
+ dh_auto_test.
+ * Update Emacs dependency and build-dependency:
+ Previously: emacs24-nox | emacs24 (>=24~) | emacs24-lucid (>=24~)
+ Now: emacs25-nox | emacs25 | emacs24-nox | emacs24
+ - emacsXY-lucid has "Provides: emacsXY".
+ - Update for emacs25, but retain emacs24 for the sake of backports.
+ - Retain emacs24-nox for the sake of the backports buildds.
+ * dh_elpa_test ignores files containing ERT tests in .git.
+ In particular, don't try to load files in .git/dgit/unpack/fake.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Mon, 19 Dec 2016 07:32:34 +0000
+
dh-elpa (1.3~bpo8+1) jessie-backports; urgency=medium
* Rebuild for jessie-backports.
diff --git a/debian/control b/debian/control
index c27963e..fe5d74f 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Uploaders:
Sean Whitton <spwhitton@spwhitton.name>,
Build-Depends:
debhelper (>= 9.20151004),
- emacs24-nox | emacs24 (>=24~) | emacs24-lucid (>=24~),
+ emacs25-nox | emacs25 | emacs24-nox | emacs24,
Standards-Version: 3.9.8
Vcs-Git: https://anonscm.debian.org/git/pkg-emacsen/pkg/dh-elpa.git
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-emacsen/pkg/dh-elpa.git/
@@ -18,7 +18,7 @@ Built-Using: ${misc:Built-Using}
Depends:
debhelper (>= 9.20151004),
libdebian-source-perl | dh-make-perl,
- emacs24-nox | emacs24 (>=24~) | emacs24-lucid (>=24~),
+ emacs25-nox | emacs25 | emacs24-nox | emacs24,
libarray-utils-perl,
libconfig-tiny-perl,
libfile-find-rule-perl,
diff --git a/dh-elpa.el b/dh-elpa.el
index 094913e..8017851 100644
--- a/dh-elpa.el
+++ b/dh-elpa.el
@@ -172,11 +172,24 @@ such a case."
"Filter a list of package.el deps DEPS for Debian.
Remove packages that are maintained outside of the elpa-*
-namespace in Debian, plus Emacs itself."
- (let ((non-elpa (list 'emacs 's 'dash 'yasnippet)))
- (cl-remove-if (lambda (dep)
- (or (memq (car dep) non-elpa)
- (package-built-in-p (car dep))))
+namespace in Debian, plus Emacs itself.
+
+Also remove built-in packages, except those built-in packages
+that are also packaged separately in Debian.
+
+These are packaged separately for two reasons:
+
+- it allows us to provide newer versions than those in Emacs core
+
+- it permits use of addons with older versions of Emacs, for
+ which the dependency is not yet a built-in package."
+ (let ((non-elpa (list 'emacs 's 'dash 'yasnippet))
+ (packaged-separately (list 'let-alist 'seq)))
+ (cl-remove-if (lambda (dep) (let ((pkg (car dep)))
+ (or (memq pkg non-elpa)
+ (and
+ (package-built-in-p pkg)
+ (not (memq pkg packaged-separately))))))
deps)))
(defun dhelpa-filter-pkg-desc (desc)
diff --git a/dh_elpa_test b/dh_elpa_test
index 09fe39d..c8ee10b 100755
--- a/dh_elpa_test
+++ b/dh_elpa_test
@@ -25,6 +25,9 @@ build-depends on elpa-buttercup. Testing with ERT will be activated
if ERT test files can be found. Neither kind of test will be
activated unless the debhelper compat level is 10 or higher.
+B<dh_elpa_test> overrides dh_auto_test(1). If you need to switch back
+to use dh_auto_test(1), use the B<disable> configuration key, below.
+
=head1 FILES
=over 4
@@ -216,7 +219,7 @@ if ($autopkgtest) {
my $rule = File::Find::Rule->new;
$rule
->or(File::Find::Rule
- ->name('.pc', 'debian')
+ ->name('.pc', 'debian', '.git')
->directory->prune->discard,
File::Find::Rule->new);
$rule
@@ -259,10 +262,19 @@ if ($autopkgtest) {
no warnings 'once';
open(OLDERR, ">&", \*STDERR);
}
+
# redirect stderr to stdout while we run our tests
+
# emacs --batch and ERT itself both produce a lot of output on
# stderr even when there has been no error, and adt-run interprets
# this as a test failure
+
+ # Recent autopkgtest has a 'allow-stderr' restriction prevents
+ # that interpretation. However, relying on that would require
+ # 'allow-stderr' to be specified in the d/tests/control file for
+ # every package using dh_elpa_test. It's cleaner just to redirect
+ # here.
+
open(STDERR, ">&STDOUT");
# unbuffer them to ensure lines appear in the right order
select STDERR; $| = 1;
diff --git a/emacsen-common/remove b/emacsen-common/remove
index d09371e..56ba5b6 100755
--- a/emacsen-common/remove
+++ b/emacsen-common/remove
@@ -18,7 +18,8 @@ case $FLAVOR in
exit 0
;;
xemacs*)
- echo remove/${ELPA_DIR}: Skipping unsupported emacs ${FLAVOUR}
+ echo remove/${ELPA_DIR}: Skipping unsupported emacs ${FLAVOUR}
+ exit 0
;;
*)
echo remove/${ELPA_DIR}: Handling removal of emacsen flavor ${FLAVOR}