summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2015-07-11 16:45:48 +0200
committerDavid Bremner <david@tethera.net>2015-07-11 16:45:48 +0200
commit9edd0c38f3ac66f0bcd4ca2a478aeb7c3ccfcaac (patch)
tree114fe46618de2ff8afb34173d68e1f30835e7db9
parentc1192df98ae04bc240eb4dfcfab7b0367f241a79 (diff)
use package.el magic to find the lisp file
Since the whole point of this package is to simplify other packages, try to set a good example.
-rwxr-xr-xdebian/rules2
-rwxr-xr-xdh_elpa5
2 files changed, 3 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 39ea658..1c6778b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,5 +6,5 @@ DESTDIR=$(CURDIR)/debian/tmp
dh $@
override_dh_auto_install:
- LISPDIR=. ./dh_elpa dh-elpa.el $(DESTDIR)/usr/share/emacs/site-lisp/elpa
+ ./dh_elpa dh-elpa.el $(DESTDIR)/usr/share/emacs/site-lisp/elpa
install -m 755 -D dh_elpa $(DESTDIR)/usr/bin/dh_elpa
diff --git a/dh_elpa b/dh_elpa
index fef3c27..47b8422 100755
--- a/dh_elpa
+++ b/dh_elpa
@@ -1,5 +1,4 @@
#!/bin/sh
-LISPDIR=${LISPDIR:-/usr/share/emacs/site-lisp/elpa/dh-elpa-${VERSION}}
-
-emacs -batch -Q -l ${LISPDIR}/dh-elpa.el -f dhelpa-batch-install-file "$@"
+emacs -batch -Q -l package -f package-initialize \
+ -l dh-elpa.el -f dhelpa-batch-install-file "$@"