summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2020-06-07 15:18:24 -0700
committerSean Whitton <spwhitton@spwhitton.name>2020-06-07 15:18:24 -0700
commitfbe57d9bd7d1b8fd8bb4c2eb9ad4160da89b5598 (patch)
treedfaa709150818b6a40ef9cc80e7bf431e90be40e
parent5e6244b47186b16b379fde746c709d06bc25a65f (diff)
parente70705e6aa7db3e314ddab9b462a60b29eaf0b14 (diff)
Merge tag 'debian/2.0.4' into dgit/buster-backports
dh-elpa release 2.0.4 for unstable (sid) [dgit] [dgit distro=debian no-split] # gpg: Signature made Mon 01 Jun 2020 05:33:48 PM MST # gpg: using RSA key 9B917007AE030E36E4FC248B695B7AE4BF066240 # gpg: Good signature from "Sean Whitton <spwhitton@spwhitton.name>" [ultimate] # Primary key fingerprint: 8DC2 487E 51AB DD90 B5C4 753F 0F56 D055 3B6D 411B # Subkey fingerprint: 9B91 7007 AE03 0E36 E4FC 248B 695B 7AE4 BF06 6240
-rw-r--r--debian/changelog31
-rw-r--r--debian/compat1
-rw-r--r--debian/control6
-rw-r--r--debian/copyright2
-rwxr-xr-xdh_elpa11
-rwxr-xr-xdh_elpa_test3
6 files changed, 44 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index df378ac..b969c19 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,31 @@
+dh-elpa (2.0.4) unstable; urgency=medium
+
+ [ David Bremner ]
+ * Enable Multi-Arch: foreign. Currently it seems like any
+ architecture-dependent variance in the behaviour of dh_elpa is
+ probably a bug.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Mon, 01 Jun 2020 17:29:26 -0700
+
+dh-elpa (2.0.3) unstable; urgency=medium
+
+ [ Nicholas D Steeves ]
+ * Fix typos in dh_elpa documentation.
+ * Clean up trailing whitespace in this changelog.
+
+ [ Sean Whitton ]
+ * dh_elpa_test(1): Note exit code requirement in docs for ert_helper
+ (Closes: #941330).
+
+ [ Daniel Kahn Gillmor ]
+ * Use secure copyright file specification URI.
+ * Update standards version to 4.4.1, no changes needed.
+ * Bump debhelper from old 10 to 12.
+ * Set debhelper-compat version in Build-Depends.
+ * Rules-Requires-Root: no
+
+ -- David Bremner <bremner@debian.org> Sun, 19 Apr 2020 08:52:10 -0300
+
dh-elpa (2.0.2~bpo10+2) buster-backports; urgency=medium
* Rebuild for buster-backports.
@@ -322,7 +350,7 @@ dh-elpa (0.0.8) unstable; urgency=medium
* Skip binary packages with no files in their package.elpa file and or
on the command line.
-
+
-- David Bremner <bremner@debian.org> Sat, 12 Sep 2015 20:54:05 -0300
dh-elpa (0.0.7) unstable; urgency=medium
@@ -377,4 +405,3 @@ dh-elpa (0.0.1) experimental; urgency=medium
* Initial upload, early adopters only.
-- David Bremner <bremner@debian.org> Sat, 11 Jul 2015 15:24:57 +0200
-
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index f599e28..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-10
diff --git a/debian/control b/debian/control
index d3f00d5..286ba93 100644
--- a/debian/control
+++ b/debian/control
@@ -6,14 +6,16 @@ Uploaders:
David Bremner <bremner@debian.org>,
Sean Whitton <spwhitton@spwhitton.name>,
Build-Depends:
- debhelper (>= 10),
+ debhelper-compat (= 12),
emacs-nox (>= 47) | emacs (>= 47.0)
-Standards-Version: 4.4.0
+Standards-Version: 4.4.1
Vcs-Git: https://salsa.debian.org/emacsen-team/dh-elpa.git
Vcs-Browser: https://salsa.debian.org/emacsen-team/dh-elpa
+Rules-Requires-Root: no
Package: dh-elpa
Architecture: all
+Multi-Arch: foreign
Depends:
debhelper (>= 9.20151004),
libdebian-source-perl | dh-make-perl (>= 0.90),
diff --git a/debian/copyright b/debian/copyright
index 5ab2d31..af76dd9 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,4 +1,4 @@
-Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Files: *
Copyright: © 2007-2015 Free Software Foundation Inc,
diff --git a/dh_elpa b/dh_elpa
index e6fd714..982ac7b 100755
--- a/dh_elpa
+++ b/dh_elpa
@@ -210,10 +210,11 @@ if ($dh{BYTECOMPILE}) {
}
PACKAGE:
-foreach my $package (@{$dh{DOPACKAGES}}) {
+foreach my $package (getpackages()) {
my $tmp=tmpdir($package);
my $file=pkgfile($package,"elpa");
+ my $skip_install = process_pkg($package) ? 0 : 1;
my $varname="ELPA_NAME_${package}";
my $elpapkg = $ENV{$varname} || $ENV{ELPA_NAME};
@@ -265,7 +266,9 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
push @actions, map { {"src" => $_} } @ARGV;
}
- next PACKAGE if (scalar(@actions) == 0);
+ log_installed_files($package, map { @{$_->{src}} } @actions);
+
+ next PACKAGE if ($skip_install or (scalar(@actions) == 0));
my $pkg_file;
my $cwd = getcwd();
@@ -367,7 +370,7 @@ Note that Emacs Lisp dependencies packaged outside the elpa-* dpkg
namespace must be specified manually. For example, the s.el library
was once provided by the binary package s-el, and at that time packages
depending on it required an explicit dependency on s-el. A dependency
-on s.el is now fulfilled automaticaly by elpa-s via ${elpa:Depends}.
+on s.el is now fulfilled automatically by elpa-s via ${elpa:Depends}.
If dh_elpa adds dependency elpa-x where x is an Emacs Lisp binary
package outside the elpa-* namespace, please file a bug against
@@ -479,7 +482,7 @@ initialization time. This is better than using
C<debian/emacsen-startup> because the forms are then added to
I<elpa-package>-autoloads.el, rather than a file in C</etc/>, as the
contents of C<debian/emacsen-startup> was. This simplifies package
-maintainance.
+maintenance.
These cookies can either annotate upstream source, or be added (along
with the relevant forms) to a file in C<debian/>, by convention
diff --git a/dh_elpa_test b/dh_elpa_test
index f0f70ca..2e8ba5f 100755
--- a/dh_elpa_test
+++ b/dh_elpa_test
@@ -85,6 +85,9 @@ The name of a *.el file containing Emacs Lisp code that will run the
ERT test suite. When this key is not defined, B<dh_elpa_test>
calls the function B<(ert-run-tests-batch-and-exit)>.
+Your helper code should ensure that Emacs exits nonzero if there were
+any test failures, or exits zero if the test suite passed.
+
Note that this is not the way to load test helpers that do needed work
but don't actually run the tests. For that, you can use something like