summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bremner <bremner@debian.org>2017-08-03 14:09:10 -0400
committerDavid Bremner <bremner@debian.org>2017-08-03 14:09:10 -0400
commitd8298d8c8b959385d64016ec82bfa38b88c043c3 (patch)
treee09f427358549f44350f181d709108894e65f8bd
parentbe6a4385e1393eb6f3709903e0f4146d47c91e17 (diff)
parent65259a660973184678a24e8e06aee836a84d4579 (diff)
Record dh-elpa (1.10) in archive suite sid
-rw-r--r--.gitattributes1
-rw-r--r--.gitignore7
-rw-r--r--debian/changelog15
-rwxr-xr-xdebian/rules1
-rwxr-xr-xelpa.pm.in (renamed from elpa.pm)2
-rw-r--r--emacsen-common/compat2
-rwxr-xr-xemacsen-common/install3
-rwxr-xr-xemacsen-common/remove7
8 files changed, 21 insertions, 17 deletions
diff --git a/.gitattributes b/.gitattributes
deleted file mode 100644
index 5d42584..0000000
--- a/.gitattributes
+++ /dev/null
@@ -1 +0,0 @@
-debian/changelog merge=dpkg-mergechangelogs
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index fccc6aa..0000000
--- a/.gitignore
+++ /dev/null
@@ -1,7 +0,0 @@
-/debian/dh-elpa.debhelper.log
-/debian/dh-elpa.postinst.debhelper
-/debian/dh-elpa.prerm.debhelper
-/debian/dh-elpa.substvars
-/debian/files
-/dh_elpa.1
-/dh_elpa_test.1
diff --git a/debian/changelog b/debian/changelog
index 40e72ec..5efd171 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,18 @@
+dh-elpa (1.10) unstable; urgency=medium
+
+ [ Sean Whitton ]
+ * Add dh-elpa-Version: field to binary package control files.
+ This tracks the dh-elpa version used to build the package, to make it
+ possible to find packages that need rebuilding against newer dh-elpa.
+
+ [ David Bremner ]
+ * Treat 'emacs' as a first class flavour, anticipating Debian emacs
+ packages using that in place of 'emacsNN'.
+ * Fix reporting of ignored flavors on removal (cosmetic change).
+ * Replace '2' in generated emacsen-common compat file
+
+ -- David Bremner <bremner@debian.org> Thu, 03 Aug 2017 14:09:10 -0400
+
dh-elpa (1.9) unstable; urgency=medium
* Drop alternative {build-,}depends on emacs24{-nox,}.
diff --git a/debian/rules b/debian/rules
index 554ca48..b5558f4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,6 +11,7 @@ override_dh_auto_build:
pod2man -c Debhelper --section=1 dh_elpa.in > dh_elpa.1
pod2man -c Debhelper --section=1 dh_elpa_test > dh_elpa_test.1
sed s/@HELPER_VERSION@/${DEB_VERSION_UPSTREAM}/ < dh_elpa.in > dh_elpa
+ sed s/@HELPER_VERSION@/${DEB_VERSION_UPSTREAM}/ < elpa.pm.in > elpa.pm
chmod 755 dh_elpa dh_elpa_test
override_dh_install:
diff --git a/elpa.pm b/elpa.pm.in
index a43f395..0e1f1e9 100755
--- a/elpa.pm
+++ b/elpa.pm.in
@@ -10,6 +10,8 @@ use Config::Tiny;
insert_after("dh_install", "dh_elpa");
+add_command_options("dh_gencontrol", "--", "-Ddh-elpa-Version=@HELPER_VERSION@");
+
# check dh_make_perl version is new enough for dh_elpa_test
my $info = Module::Metadata->new_from_module("Debian::Control");
my $version = Dpkg::Version->new($info->version());
diff --git a/emacsen-common/compat b/emacsen-common/compat
index 0cfbf08..573541a 100644
--- a/emacsen-common/compat
+++ b/emacsen-common/compat
@@ -1 +1 @@
-2
+0
diff --git a/emacsen-common/install b/emacsen-common/install
index 2e11984..2d29e75 100755
--- a/emacsen-common/install
+++ b/emacsen-common/install
@@ -7,9 +7,6 @@ ELPA_DIR=#ELPAPACKAGE#-#ELPAVERSION#
FLAVOR=$1
case $FLAVOR in
- emacs)
- exit 0
- ;;
emacs2[0123]*)
echo install/${ELPA_DIR}: Skipping obsolete emacs ${FLAVOR}
exit 0
diff --git a/emacsen-common/remove b/emacsen-common/remove
index 56ba5b6..01a7741 100755
--- a/emacsen-common/remove
+++ b/emacsen-common/remove
@@ -10,15 +10,12 @@ elc_dir="${elpa_root}/${ELPA_DIR}"
FLAVOR=$1
case $FLAVOR in
- emacs)
- exit 0
- ;;
emacs2[0123]*)
- echo remove/${ELPA_DIR}: Skipping obsolete emacs ${FLAVOUR}
+ echo remove/${ELPA_DIR}: Skipping obsolete emacs ${FLAVOR}
exit 0
;;
xemacs*)
- echo remove/${ELPA_DIR}: Skipping unsupported emacs ${FLAVOUR}
+ echo remove/${ELPA_DIR}: Skipping unsupported emacs ${FLAVOR}
exit 0
;;
*)