summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bremner <bremner@debian.org>2019-09-02 12:54:26 -0300
committerDavid Bremner <bremner@debian.org>2019-09-02 12:57:15 -0300
commitdf5ebea83106bb6133b3d3bba068c4e645b0a04b (patch)
tree2c897f61ebc0c39655d95934b4a76d65258e4cb5
parent0ab710129b95adaa7115577ea505378b3effb38a (diff)
drop sedding of perl filesdebian/2.0archive/debian/2.0
The embedding of the version is not used, so no point in paying for the extra complication
-rw-r--r--debian/changelog3
-rw-r--r--debian/clean1
-rwxr-xr-xdebian/rules5
-rwxr-xr-xdh_elpa (renamed from dh_elpa.in)1
-rw-r--r--[-rwxr-xr-x]elpa.pm (renamed from elpa.pm.in)2
5 files changed, 3 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 02c3834..c25da5a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,8 +3,9 @@ dh-elpa (2.0) experimental; urgency=medium
* move bulk of maintainer scripts to a helper package that can be updated (Closes: #935766).
* add binary package dh-elpa-helper
* add dependency on dh-elpa-helper packages built with dh_elpa
+ * stop embedding version in dh_elpa, elpa.pm
- -- David Bremner <bremner@debian.org> Mon, 02 Sep 2019 12:06:06 -0300
+ -- David Bremner <bremner@debian.org> Mon, 02 Sep 2019 12:51:33 -0300
dh-elpa (1.16) unstable; urgency=high
diff --git a/debian/clean b/debian/clean
index 3c63b62..a0c81d1 100644
--- a/debian/clean
+++ b/debian/clean
@@ -1,3 +1,2 @@
dh_elpa.1
dh_elpa_test.1
-dh_elpa
diff --git a/debian/rules b/debian/rules
index 232b01a..c93d80f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,11 +10,8 @@ ELPA_NAME_dh-elpa=dh-elpa
dh $@
override_dh_auto_build:
- pod2man -c Debhelper --section=1 dh_elpa.in > dh_elpa.1
+ pod2man -c Debhelper --section=1 dh_elpa > dh_elpa.1
pod2man -c Debhelper --section=1 dh_elpa_test > dh_elpa_test.1
- sed s/@HELPER_VERSION@/${DEB_VERSION_UPSTREAM}/ < dh_elpa.in > dh_elpa
- sed s/@HELPER_VERSION@/${DEB_VERSION_UPSTREAM}/ < elpa.pm.in > elpa.pm
- chmod 755 dh_elpa dh_elpa_test
override_dh_install:
dh_install
diff --git a/dh_elpa.in b/dh_elpa
index 11cbfc9..e6fd714 100755
--- a/dh_elpa.in
+++ b/dh_elpa
@@ -270,7 +270,6 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my $pkg_file;
my $cwd = getcwd();
my $tempdir = "${cwd}/debian/.debhelper/elpa";
- my $helper_version = '@HELPER_VERSION@';
my @extra_args = ( $tempdir );
my $emacs_loadpath = "";
diff --git a/elpa.pm.in b/elpa.pm
index 51a58ae..a43f395 100755..100644
--- a/elpa.pm.in
+++ b/elpa.pm
@@ -10,8 +10,6 @@ use Config::Tiny;
insert_after("dh_install", "dh_elpa");
-# add_command_options("dh_gencontrol", "--", "-Ddh-elpa-Version=@HELPER_VERSION@");
-
# check dh_make_perl version is new enough for dh_elpa_test
my $info = Module::Metadata->new_from_module("Debian::Control");
my $version = Dpkg::Version->new($info->version());