summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2020-11-07 12:49:34 -0700
committerSean Whitton <spwhitton@spwhitton.name>2020-11-07 12:49:34 -0700
commit495190387ffb5fbdcb00cdf48bdc777f414673e0 (patch)
treeb2792c685c581e9a05d029bed974bda97615f33d
parenta42ae0a4e1b9c0d95cd3315ec64c644622d763e8 (diff)
parent7bd3765e5ddf50722fc92a8c72558f0d92a3c8b6 (diff)
Merge tag 'debian/2.0.6' into dgit/buster-backports
dh-elpa release 2.0.6 for unstable (sid) [dgit] [dgit distro=debian no-split] # gpg: Signature made Thu 29 Oct 2020 04:25:19 AM MST # gpg: using RSA key 922C87617C1A6344A263A7EA0345391B55AA1521 # gpg: Can't check signature: No public key
-rw-r--r--debian/changelog14
-rw-r--r--dh-elpa.el2
-rwxr-xr-xhelper/install2
3 files changed, 16 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index b23def6..39daae5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+dh-elpa (2.0.6) unstable; urgency=medium
+
+ * Bug fix: "Can't install non-ELPA package due to typo in helper
+ script", thanks to Youhei SASAKI (Closes: #973346).
+
+ -- David Bremner <bremner@debian.org> Thu, 29 Oct 2020 08:17:42 -0300
+
+dh-elpa (2.0.5) unstable; urgency=medium
+
+ * Add xref and project to the list of built-in packages that we also
+ have packaged separately (Closes: #972995).
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Tue, 27 Oct 2020 09:23:33 -0700
+
dh-elpa (2.0.4~bpo10+1) buster-backports; urgency=medium
* Rebuild for buster-backports.
diff --git a/dh-elpa.el b/dh-elpa.el
index 3643452..f8d2814 100644
--- a/dh-elpa.el
+++ b/dh-elpa.el
@@ -184,7 +184,7 @@ These are packaged separately for two reasons:
- it permits use of addons with older versions of Emacs, for
which the dependency is not yet a built-in package."
(let ((non-elpa (list 'emacs))
- (packaged-separately (list 'let-alist 'seq)))
+ (packaged-separately (list 'let-alist 'seq 'xref 'project)))
(cl-remove-if (lambda (dep) (let ((pkg (car dep)))
(or (memq pkg non-elpa)
(and
diff --git a/helper/install b/helper/install
index 622cbc7..1a2eb8a 100755
--- a/helper/install
+++ b/helper/install
@@ -13,7 +13,7 @@ PATH=/usr/sbin:/usr/bin:/sbin:/bin
FLAVOR=$1
ELPA_PACKAGE=$2
ELPA_VERSION=$3
-ELPA_LOADPATH=$4
+ELPA_LOAD_PATH=$4
ELPA_DIR=${ELPA_PACKAGE}-${ELPA_VERSION}