summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2018-08-19 18:43:56 -0300
committerDavid Bremner <david@tethera.net>2018-08-19 18:43:56 -0300
commitc565c3f04d2a422bdf17e9bf72fd4b999d515c3f (patch)
treedee5f3ebba364f4705e6bb836e21c9ee724b92f2
parent85f9e790a4c381af2449ae933ba0dd168837223e (diff)
document ELPA_NAME
-rwxr-xr-xdh_elpa.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/dh_elpa.in b/dh_elpa.in
index 9ff665e..9308d58 100755
--- a/dh_elpa.in
+++ b/dh_elpa.in
@@ -370,3 +370,26 @@ version strings Emacs will accept (see the docstring for the Emacs
function `version-to-list' for details). dh_elpa will error out if
the version cannot be translated. You should resort to patching in a
Package-Version header or adding a *-pkg.el file.
+
+=head2 Specifying the (Emacs) package name
+
+Every Emacs package has a name (e.g. C<magit>, C<circe>, or
+C<tetris>). This name is encoded in the source, either using a special
+comment or the C<*-pkg.el> file. B<dh_elpa> needs to know what this name
+is. For packages compliant with the Debian Emacsen Team addons policy
+(L<https://wiki.debian.org/EmacsenTeam>) this will prefixed with
+'elpa-' to become the Debian (apt/dpkg) package name. For Debian
+packages not following this naming convention, B<dh_elpa> will by
+default try using the Debian package name as the Emacs package name.
+If this does not work for your package, you can specify
+environment variable B<ELPA_NAME> in debian/rules:
+
+=over 4
+
+ ELPA_NAME=tpp-mode
+ export ELPA_NAME
+
+=back
+
+You can also specify the name on a per binary package basis with
+C<ELPA_NAME_binary-package-name>.