summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2015-07-11 16:34:41 +0200
committerDavid Bremner <david@tethera.net>2015-07-11 16:34:41 +0200
commitd6853ff7eccf072835f7a93f6a35fc59d7e559fe (patch)
tree38eb4e55d9e0b59e41bb251d1ef530cd9613a00d /debian/rules
parent55ddc9496480566ca35640546cf52cb53258b305 (diff)
make dh_elpa actually work with an installed elisp file.
This is not the most elegant solution in the world, but impovements only need to change this package's debian/rules.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 1c6778b..39ea658 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,5 +6,5 @@ DESTDIR=$(CURDIR)/debian/tmp
dh $@
override_dh_auto_install:
- ./dh_elpa dh-elpa.el $(DESTDIR)/usr/share/emacs/site-lisp/elpa
+ LISPDIR=. ./dh_elpa dh-elpa.el $(DESTDIR)/usr/share/emacs/site-lisp/elpa
install -m 755 -D dh_elpa $(DESTDIR)/usr/bin/dh_elpa