summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDavid Bremner <bremner@debian.org>2015-10-28 22:38:13 -0300
committerDavid Bremner <bremner@debian.org>2015-10-28 22:44:27 -0300
commitb32d18a72b6222a70a8d3db21887a36ccd2d5ecc (patch)
treeb127c3a2974ac3889516f86a9560a6accfe8738f /debian/rules
parentb3f546e393916c25fad8b7fd74457961a7507b0e (diff)
release 0.0.16: add misc:Built-Using substvar
also depend on perl, while we're at it.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 49e5292..ccb9394 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,14 @@
#!/usr/bin/make -f
DESTDIR=$(CURDIR)/debian/tmp
-
+VERSION=$(shell dpkg-parsechangelog | sed -n 's/^Version: //p')
%:
dh $@
override_dh_auto_build:
- pod2man -c Debhelper --section=1 dh_elpa > dh_elpa.1
+ pod2man -c Debhelper --section=1 dh_elpa.in > dh_elpa.1
+ sed s/@HELPER_VERSION@/${VERSION}/ < dh_elpa.in > dh_elpa
+ chmod 755 dh_elpa
override_dh_install:
dh_install