summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2015-07-11 22:40:26 +0200
committerDavid Bremner <david@tethera.net>2015-07-12 08:08:39 +0200
commit45ac760c6da6cd86660ceac632525593477299c8 (patch)
tree62124b132fc442c5172dcd163aea305b6b8c3013 /debian
parent82a2216013af44a82b78fa9c999d4fec1501e3fc (diff)
minimal conversion to perl / debhelper lib
It turns out this isn't $MESSY_CONFLICT_ZONE, there are rules about writing debhelper extensions. This is mainly cargo culting from dh_installdocs. - compute destination directory, support multiple binary packages. - add debian/elpa file, test the "standard" codepath. Still not very standard because it's a single file elpa package.
Diffstat (limited to 'debian')
-rw-r--r--debian/elpa1
-rw-r--r--debian/install1
-rwxr-xr-xdebian/rules2
3 files changed, 2 insertions, 2 deletions
diff --git a/debian/elpa b/debian/elpa
new file mode 100644
index 0000000..abf136d
--- /dev/null
+++ b/debian/elpa
@@ -0,0 +1 @@
+*.el
diff --git a/debian/install b/debian/install
index adc3fdf..e772481 100644
--- a/debian/install
+++ b/debian/install
@@ -1,2 +1 @@
-usr/share/emacs
usr/bin
diff --git a/debian/rules b/debian/rules
index 1c6778b..d0aed4d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,5 +6,5 @@ DESTDIR=$(CURDIR)/debian/tmp
dh $@
override_dh_auto_install:
- ./dh_elpa dh-elpa.el $(DESTDIR)/usr/share/emacs/site-lisp/elpa
+ ./dh_elpa
install -m 755 -D dh_elpa $(DESTDIR)/usr/bin/dh_elpa