summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2017-08-02 14:32:59 -0400
committerSean Whitton <spwhitton@spwhitton.name>2017-08-02 14:32:59 -0400
commitb556f15076ac7ddfc503bca2fceceee3c2759a88 (patch)
tree57b7770fb2f7b7731403505f0da38d458a34dbe2 /debian
parentbe6a4385e1393eb6f3709903e0f4146d47c91e17 (diff)
add dh-elpa-Version: binary package field
There is a debhelper mechanism for dh_* tools to embed their versions in generated maintscripts, but our emacsen-common maintscripts are not true maintscripts, so we can't use that mechanism. Using a binary package field makes it possible for us to find packages that need rebuilding without looking inside the contents of any binary packages.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules1
2 files changed, 9 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 40e72ec..1c17bd6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+dh-elpa (1.10) UNRELEASED; urgency=medium
+
+ * Add dh-elpa-Version: field to binary package control files.
+ This tracks the dh-elpa version used to build the package, to make it
+ possible to find packages that need rebuilding against newer dh-elpa.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Wed, 02 Aug 2017 14:22:25 -0400
+
dh-elpa (1.9) unstable; urgency=medium
* Drop alternative {build-,}depends on emacs24{-nox,}.
diff --git a/debian/rules b/debian/rules
index 554ca48..b5558f4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,6 +11,7 @@ override_dh_auto_build:
pod2man -c Debhelper --section=1 dh_elpa.in > dh_elpa.1
pod2man -c Debhelper --section=1 dh_elpa_test > dh_elpa_test.1
sed s/@HELPER_VERSION@/${DEB_VERSION_UPSTREAM}/ < dh_elpa.in > dh_elpa
+ sed s/@HELPER_VERSION@/${DEB_VERSION_UPSTREAM}/ < elpa.pm.in > elpa.pm
chmod 755 dh_elpa dh_elpa_test
override_dh_install: