summaryrefslogtreecommitdiff
path: root/dh_elpa
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2015-07-11 16:34:41 +0200
committerDavid Bremner <david@tethera.net>2015-07-11 16:34:41 +0200
commitd6853ff7eccf072835f7a93f6a35fc59d7e559fe (patch)
tree38eb4e55d9e0b59e41bb251d1ef530cd9613a00d /dh_elpa
parent55ddc9496480566ca35640546cf52cb53258b305 (diff)
make dh_elpa actually work with an installed elisp file.
This is not the most elegant solution in the world, but impovements only need to change this package's debian/rules.
Diffstat (limited to 'dh_elpa')
-rwxr-xr-xdh_elpa4
1 files changed, 3 insertions, 1 deletions
diff --git a/dh_elpa b/dh_elpa
index 93332ce..fef3c27 100755
--- a/dh_elpa
+++ b/dh_elpa
@@ -1,3 +1,5 @@
#!/bin/sh
-emacs -batch -Q -l dh-elpa.el -f dhelpa-batch-install-file "$@"
+LISPDIR=${LISPDIR:-/usr/share/emacs/site-lisp/elpa/dh-elpa-${VERSION}}
+
+emacs -batch -Q -l ${LISPDIR}/dh-elpa.el -f dhelpa-batch-install-file "$@"