summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rwxr-xr-xdh_elpa2
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 9485a57..7bed9a9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,9 +2,9 @@ dh-elpa (0.0.5) unstable; urgency=medium
* Use debian/.debhelper/elpa for temp files. This allows easier
debugging.
- * Make inability to compute elpa name a fatal error.
+ * Add a check for ${elpa_name}-pkg.el in multi-file packages
- -- David Bremner <bremner@debian.org> Fri, 21 Aug 2015 10:40:46 +0200
+ -- David Bremner <bremner@debian.org> Sun, 23 Aug 2015 10:55:01 +0200
dh-elpa (0.0.4) unstable; urgency=medium
diff --git a/dh_elpa b/dh_elpa
index b62050d..c84f94c 100755
--- a/dh_elpa
+++ b/dh_elpa
@@ -138,6 +138,8 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
isnative($package);
if ($file) {
@files=filearray($file, ".");
+ scalar(@files) == 1 || grep { m/\b${elpapkg}-pkg.el$/ } @files or
+ error "missing ${elpapkg}-pkg.el";
}
if (($package eq $dh{FIRSTPACKAGE} || $dh{PARAMS_ALL})
&& @ARGV) {