summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitattributes1
-rw-r--r--.gitignore7
-rw-r--r--debian/changelog15
-rw-r--r--debian/control4
-rwxr-xr-xdh_elpa_test14
5 files changed, 38 insertions, 3 deletions
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 0000000..5d42584
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1 @@
+debian/changelog merge=dpkg-mergechangelogs
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fccc6aa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+/debian/dh-elpa.debhelper.log
+/debian/dh-elpa.postinst.debhelper
+/debian/dh-elpa.prerm.debhelper
+/debian/dh-elpa.substvars
+/debian/files
+/dh_elpa.1
+/dh_elpa_test.1
diff --git a/debian/changelog b/debian/changelog
index 8a36db7..bed06eb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,18 @@
+dh-elpa (1.4) unstable; urgency=medium
+
+ * Add note to dh_elpa_test manpage about disabling its override of
+ dh_auto_test.
+ * Update Emacs dependency and build-dependency:
+ Previously: emacs24-nox | emacs24 (>=24~) | emacs24-lucid (>=24~)
+ Now: emacs25-nox | emacs25 | emacs24-nox | emacs24
+ - emacsXY-lucid has "Provides: emacsXY".
+ - Update for emacs25, but retain emacs24 for the sake of backports.
+ - Retain emacs24-nox for the sake of the backports buildds.
+ * dh_elpa_test ignores files containing ERT tests in .git.
+ In particular, don't try to load files in .git/dgit/unpack/fake.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Mon, 19 Dec 2016 07:32:34 +0000
+
dh-elpa (1.3) unstable; urgency=medium
* Fix version comparison in elpa.pm.
diff --git a/debian/control b/debian/control
index dfc829a..24c9065 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Uploaders:
Sean Whitton <spwhitton@spwhitton.name>,
Build-Depends:
debhelper (>= 9.20151004),
- emacs24-nox | emacs24 (>=24~) | emacs24-lucid (>=24~),
+ emacs25-nox | emacs25 | emacs24-nox | emacs24,
Standards-Version: 3.9.8
Vcs-Git: https://anonscm.debian.org/git/pkg-emacsen/pkg/dh-elpa.git
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-emacsen/pkg/dh-elpa.git/
@@ -18,7 +18,7 @@ Built-Using: ${misc:Built-Using}
Depends:
debhelper (>= 9.20151004),
libdebian-source-perl | dh-make-perl (>= 0.90),
- emacs24-nox | emacs24 (>=24~) | emacs24-lucid (>=24~),
+ emacs25-nox | emacs25 | emacs24-nox | emacs24,
libarray-utils-perl,
libconfig-tiny-perl,
libfile-find-rule-perl,
diff --git a/dh_elpa_test b/dh_elpa_test
index 09fe39d..c8ee10b 100755
--- a/dh_elpa_test
+++ b/dh_elpa_test
@@ -25,6 +25,9 @@ build-depends on elpa-buttercup. Testing with ERT will be activated
if ERT test files can be found. Neither kind of test will be
activated unless the debhelper compat level is 10 or higher.
+B<dh_elpa_test> overrides dh_auto_test(1). If you need to switch back
+to use dh_auto_test(1), use the B<disable> configuration key, below.
+
=head1 FILES
=over 4
@@ -216,7 +219,7 @@ if ($autopkgtest) {
my $rule = File::Find::Rule->new;
$rule
->or(File::Find::Rule
- ->name('.pc', 'debian')
+ ->name('.pc', 'debian', '.git')
->directory->prune->discard,
File::Find::Rule->new);
$rule
@@ -259,10 +262,19 @@ if ($autopkgtest) {
no warnings 'once';
open(OLDERR, ">&", \*STDERR);
}
+
# redirect stderr to stdout while we run our tests
+
# emacs --batch and ERT itself both produce a lot of output on
# stderr even when there has been no error, and adt-run interprets
# this as a test failure
+
+ # Recent autopkgtest has a 'allow-stderr' restriction prevents
+ # that interpretation. However, relying on that would require
+ # 'allow-stderr' to be specified in the d/tests/control file for
+ # every package using dh_elpa_test. It's cleaner just to redirect
+ # here.
+
open(STDERR, ">&STDOUT");
# unbuffer them to ensure lines appear in the right order
select STDERR; $| = 1;