summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/TODO6
-rw-r--r--debian/changelog6
-rwxr-xr-xemacsen-common/install5
3 files changed, 9 insertions, 8 deletions
diff --git a/debian/TODO b/debian/TODO
index 58457f1..9d18bb3 100644
--- a/debian/TODO
+++ b/debian/TODO
@@ -1,7 +1,5 @@
-*- org -*-
* missing features
-** postinst
-*** TODO symlink all files/directories into flavour specific directory
- This is needed for packages like geiser that look relative to the
- elisp directory for non-elisp (e.g. scheme) files.
+** info
+ - completely untested at the moment
diff --git a/debian/changelog b/debian/changelog
index becfe65..e255ab3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,12 @@
-dh-elpa (0.0.5) UNRELEASED; urgency=medium
+dh-elpa (0.0.5) unstable; urgency=medium
* Use debian/.debhelper/elpa for temp files. This allows easier
debugging.
* Add a check for ${elpa_name}-pkg.el in multi-file packages
+ * Link all top level files/directories into flavour directory, not
+ just *.el
- -- David Bremner <bremner@debian.org> Tue, 01 Sep 2015 08:33:30 -0300
+ -- David Bremner <bremner@debian.org> Tue, 01 Sep 2015 19:09:51 -0300
dh-elpa (0.0.4) unstable; urgency=medium
diff --git a/emacsen-common/install b/emacsen-common/install
index d24e6a5..090505f 100755
--- a/emacsen-common/install
+++ b/emacsen-common/install
@@ -38,8 +38,9 @@ echo install/${ELPA_PACKAGE}: byte-compiling for ${FLAVOR}
# Create symlinks to the .el files (see section 6E in debian-emacs
# polcy). This makes complation easy, and also allows find-function
-# and find-library to work properly.
-(cd ${elc_dir} && cp -sf ${el_dir}/*.el .)
+# and find-library to work properly. Also link all other top level
+# files and directories into the flavor directory
+(cd ${elc_dir} && ln -sf ${el_dir}/* .)
# Byte compile them
(cd ${elc_dir}