summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xemacsen-common/remove6
2 files changed, 10 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index ec4c009..7d6f009 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dh-elpa (0.0.13) unstable; urgency=medium
+
+ * remove /usr/share/${FLAVOUR}/site-lisp/elpa on last package removal.
+
+ -- David Bremner <bremner@debian.org> Tue, 06 Oct 2015 21:21:39 -0300
+
dh-elpa (0.0.12) unstable; urgency=medium
* Replace use of private function `autoscript_sed' from Dh_Lib
diff --git a/emacsen-common/remove b/emacsen-common/remove
index dfa0df7..89109fa 100755
--- a/emacsen-common/remove
+++ b/emacsen-common/remove
@@ -5,7 +5,8 @@ set -e
ELPA_DIR=#ELPAPACKAGE#-#ELPAVERSION#
FLAVOR=$1
-elc_dir=/usr/share/${FLAVOR}/site-lisp/elpa/${ELPA_DIR}
+elpa_root="/usr/share/${FLAVOR}/site-lisp/elpa"
+elc_dir="${elpa_root}/${ELPA_DIR}"
FLAVOR=$1
case $FLAVOR in
@@ -29,7 +30,8 @@ find ${elc_dir} -type l -delete
rm -f ${elc_dir}/Install.log*
if test -e "${elc_dir}"
then
- rmdir --ignore-fail-on-non-empty "${elc_dir}"
+ rmdir --ignore-fail-on-non-empty "${elc_dir}"
+ rmdir --ignore-fail-on-non-empty "${elpa_root}"
fi
exit 0;