summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rwxr-xr-xemacsen-common/install2
2 files changed, 5 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index d73ec2b..8408d67 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,8 +3,11 @@ dh-elpa (0.0.9) unstable; urgency=medium
* Bug fix: "dh-elpa should provide substvar for depends field", thanks
to Thomas Koch (Closes: #799208). Currently we add only an unversioned
depends on emacsen-common.
+ * Bug fix: "an elpa package cannot require a non elpa debian package",
+ thanks to Remi Vanicat (Closes: #798576). As Remi suggests, use -q
+ instead of -Q to byte-compile files.
- -- David Bremner <bremner@debian.org> Wed, 16 Sep 2015 19:41:20 -0300
+ -- David Bremner <bremner@debian.org> Thu, 17 Sep 2015 07:45:15 -0300
dh-elpa (0.0.8) unstable; urgency=medium
diff --git a/emacsen-common/install b/emacsen-common/install
index 090505f..88ed6cf 100755
--- a/emacsen-common/install
+++ b/emacsen-common/install
@@ -45,7 +45,7 @@ echo install/${ELPA_PACKAGE}: byte-compiling for ${FLAVOR}
# Byte compile them
(cd ${elc_dir}
set +e
- ${FLAVOR} -Q -batch -l package \
+ ${FLAVOR} -q -batch -l package \
--eval "(add-to-list 'package-directory-list \"$src_dir\")" \
-f package-initialize -f batch-byte-compile *.el > Install.log 2>&1
if test $? -ne 0