summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_elpa.in30
2 files changed, 36 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 298e650..1b7d2a1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dh-elpa (0.0.17) UNRELEASED; urgency=medium
+
+ * Document substvars
+
+ -- David Bremner <bremner@debian.org> Thu, 29 Oct 2015 07:48:52 -0300
+
dh-elpa (0.0.16) unstable; urgency=medium
* Bug fix: "Add Built-Using substvars entry", thanks to Hilko Bengen
diff --git a/dh_elpa.in b/dh_elpa.in
index 7a196e6..8803f42 100755
--- a/dh_elpa.in
+++ b/dh_elpa.in
@@ -235,6 +235,23 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
+=head1 SUBSTVARS
+
+dh_elpa currently defines two substvars (cf. deb-substvars(5)) that
+can be used in debian/control
+
+=over 4
+
+=item ${misc:Depends}
+
+These are dependencies needed by every dh_elpa based package.
+
+=item ${misc:Built-Using}
+
+This adds a value suitable for a Built-Using header identifying the version of dh_elpa used at build time.
+
+=back
+
=head1 EXAMPLES
Here is an example of using the helper in a dh(1) style debian/rules
@@ -247,5 +264,18 @@ override_dh_install:
=back
+Here is an example of a binary package stanza using dh_elpa generated substvars
+
+=over 4
+
+ Package: elpa-hello
+ Architecture: all
+ Depends: ${misc:Depends}
+ Built-Using: ${misc:Built-Using}
+ Description: Emacs addon to say hello
+ The Emacs editor addon likes to wave and say hello.
+
+=back
+
=cut