summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitattributes1
-rw-r--r--.gitignore7
-rw-r--r--debian/changelog10
-rw-r--r--dh-elpa.el2
-rwxr-xr-xdh_elpa.in6
-rwxr-xr-xdh_elpa_test2
6 files changed, 23 insertions, 5 deletions
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 0000000..5d42584
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1 @@
+debian/changelog merge=dpkg-mergechangelogs
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fccc6aa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+/debian/dh-elpa.debhelper.log
+/debian/dh-elpa.postinst.debhelper
+/debian/dh-elpa.prerm.debhelper
+/debian/dh-elpa.substvars
+/debian/files
+/dh_elpa.1
+/dh_elpa_test.1
diff --git a/debian/changelog b/debian/changelog
index 295ea68..0eef4db 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+dh-elpa (1.7) unstable; urgency=medium
+
+ * Properly implement ignoring files containing ERT tests in .git.
+ dh-elpa 1.4 ignored them in only --autopkgtest mode.
+ * Update list of addons packaged outside of the elpa-* namespace.
+ - Remove s, dash and yasnippet.
+ * Manpage grammar fix.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Sun, 18 Jun 2017 21:43:37 +0100
+
dh-elpa (1.6) unstable; urgency=medium
* Add an "exit 0" to xemacs case of remove script (Closes: #850036).
diff --git a/dh-elpa.el b/dh-elpa.el
index 8017851..3643452 100644
--- a/dh-elpa.el
+++ b/dh-elpa.el
@@ -183,7 +183,7 @@ These are packaged separately for two reasons:
- it permits use of addons with older versions of Emacs, for
which the dependency is not yet a built-in package."
- (let ((non-elpa (list 'emacs 's 'dash 'yasnippet))
+ (let ((non-elpa (list 'emacs))
(packaged-separately (list 'let-alist 'seq)))
(cl-remove-if (lambda (dep) (let ((pkg (car dep)))
(or (memq pkg non-elpa)
diff --git a/dh_elpa.in b/dh_elpa.in
index 5e5828b..14e7396 100755
--- a/dh_elpa.in
+++ b/dh_elpa.in
@@ -327,9 +327,9 @@ substvars
If dh_elpa can't determine the package version by looking at *.el
files (usually because upstream has failed to include the proper
headers or *-pkg.el file), it will fallback to the
-DEB_UPSTREAM_VERSION and DEB_VERSION_UPSTREAM. An easy way to set one
-of these based on your latest Debian changelog entry is just to
-prepend the following to your rules file:
+DEB_UPSTREAM_VERSION and DEB_VERSION_UPSTREAM environment variables.
+An easy way to set one of these based on your latest Debian changelog
+entry is just to prepend the following to your rules file:
=over 4
diff --git a/dh_elpa_test b/dh_elpa_test
index c8ee10b..2c49904 100755
--- a/dh_elpa_test
+++ b/dh_elpa_test
@@ -303,7 +303,7 @@ if ($control->source->Build_Depends->has( "elpa-buttercup" )) {
my $rule = File::Find::Rule->new;
$rule
->or(File::Find::Rule
- ->name('.pc', 'debian')
+ ->name('.pc', 'debian', '.git')
->directory->prune->discard,
File::Find::Rule->new);
$rule