summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_elpa_test3
2 files changed, 9 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index f808646..55f2a41 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dh-elpa (2.0.12) unstable; urgency=medium
+
+ * Set temporary native code cached directory when running tests.
+
+ -- David Bremner <bremner@debian.org> Sun, 25 Sep 2022 08:15:00 -0300
+
dh-elpa (2.0.11) unstable; urgency=medium
* Depend (temporarily?) on emacs-el as workaround for #1017698
diff --git a/dh_elpa_test b/dh_elpa_test
index 206ae46..411b94e 100755
--- a/dh_elpa_test
+++ b/dh_elpa_test
@@ -9,6 +9,7 @@ dh_elpa_test - run ELPA package testsuites
use strict;
use warnings;
no warnings "experimental::smartmatch";
+use File::Temp qw/tempdir/;
=head1 SYNOPSIS
@@ -347,6 +348,8 @@ my @ert_files = $rule->in('.');
if (@ert_files) {
my @args = qw{ emacs -batch -Q -l package };
+ my $tmpdir = tempdir (CLEANUP => 1);
+ push @args, ("--eval", "(setq native-compile-target-directory \"$tmpdir\")");
push @args, ("--eval", "(add-to-list 'package-directory-list \"$dhelpadir\")");
push @args, ("--eval", "(add-to-list 'package-directory-list \"$elpadir\")");
push @args, ("-f", "package-initialize");