summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_elpa_test2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 6e9ad04..c1de50b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,8 @@ dh-elpa (1.4) UNRELEASED; urgency=medium
- emacsXY-lucid has "Provides: emacsXY".
- Update for emacs25, but retain emacs24 for the sake of backports.
- Retain emacs24-nox for the sake of the backports buildds.
+ * dh_elpa_test ignores files containing ERT tests in .git.
+ In particular, don't try to load files in .git/dgit/unpack/fake.
-- Sean Whitton <spwhitton@spwhitton.name> Thu, 24 Nov 2016 19:26:49 -0700
diff --git a/dh_elpa_test b/dh_elpa_test
index c010a90..c8ee10b 100755
--- a/dh_elpa_test
+++ b/dh_elpa_test
@@ -219,7 +219,7 @@ if ($autopkgtest) {
my $rule = File::Find::Rule->new;
$rule
->or(File::Find::Rule
- ->name('.pc', 'debian')
+ ->name('.pc', 'debian', '.git')
->directory->prune->discard,
File::Find::Rule->new);
$rule