summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b5558f4
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+
+include /usr/share/dpkg/pkg-info.mk
+export DEB_VERSION_UPSTREAM
+DESTDIR=$(CURDIR)/debian/tmp
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ pod2man -c Debhelper --section=1 dh_elpa.in > dh_elpa.1
+ pod2man -c Debhelper --section=1 dh_elpa_test > dh_elpa_test.1
+ sed s/@HELPER_VERSION@/${DEB_VERSION_UPSTREAM}/ < dh_elpa.in > dh_elpa
+ sed s/@HELPER_VERSION@/${DEB_VERSION_UPSTREAM}/ < elpa.pm.in > elpa.pm
+ chmod 755 dh_elpa dh_elpa_test
+
+override_dh_install:
+ dh_install
+ dh_installman dh_elpa.1 dh_elpa_test.1
+ ./dh_elpa --no-byte-compile
+
+override_dh_auto_install:
+ install -m 755 -D dh_elpa $(DESTDIR)/usr/bin/dh_elpa
+ install -m 755 -D dh_elpa_test $(DESTDIR)/usr/bin/dh_elpa_test