summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules6
3 files changed, 14 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 8fb9fdd..298e650 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+dh-elpa (0.0.16) unstable; urgency=medium
+
+ * Bug fix: "Add Built-Using substvars entry", thanks to Hilko Bengen
+ (Closes: #803350).
+ * Add depends on ${perl:Depends}
+
+ -- David Bremner <bremner@debian.org> Wed, 28 Oct 2015 22:43:59 -0300
+
dh-elpa (0.0.15) unstable; urgency=medium
* Also ignore emacs20
diff --git a/debian/control b/debian/control
index 4e284be..8da099a 100644
--- a/debian/control
+++ b/debian/control
@@ -11,7 +11,8 @@ Vcs-Browser: http://anonscm.debian.org/cgit/pkg-emacsen/pkg/dh-elpa.git/
Package: dh-elpa
Architecture: all
-Depends: ${misc:Depends}, emacs24-nox | emacs24 (>=24~) | emacs24-lucid (>=24~)
+Built-Using: ${misc:Built-Using}
+Depends: ${misc:Depends}, ${perl:Depends}, emacs24-nox | emacs24 (>=24~) | emacs24-lucid (>=24~)
Description: Debian helper tools for packaging emacs lisp extensions
This package provides a helper for packaging emacs lisp extensions
in a way compatible with the GNU Emacs 'elpa' package repository.
diff --git a/debian/rules b/debian/rules
index 49e5292..ccb9394 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,14 @@
#!/usr/bin/make -f
DESTDIR=$(CURDIR)/debian/tmp
-
+VERSION=$(shell dpkg-parsechangelog | sed -n 's/^Version: //p')
%:
dh $@
override_dh_auto_build:
- pod2man -c Debhelper --section=1 dh_elpa > dh_elpa.1
+ pod2man -c Debhelper --section=1 dh_elpa.in > dh_elpa.1
+ sed s/@HELPER_VERSION@/${VERSION}/ < dh_elpa.in > dh_elpa
+ chmod 755 dh_elpa
override_dh_install:
dh_install