summaryrefslogtreecommitdiff
path: root/dh_elpa
diff options
context:
space:
mode:
Diffstat (limited to 'dh_elpa')
-rwxr-xr-xdh_elpa42
1 files changed, 42 insertions, 0 deletions
diff --git a/dh_elpa b/dh_elpa
index 83db575..fb6214b 100755
--- a/dh_elpa
+++ b/dh_elpa
@@ -1,5 +1,11 @@
#!/usr/bin/perl
+=head1 NAME
+
+dh_elpa - install emacs lisp packages into package build directories
+
+=cut
+
use strict;
use Cwd qw{ getcwd };
use File::Temp qw{ tempdir tempfile};
@@ -7,6 +13,27 @@ use IO::Handle;
use Debian::Debhelper::Dh_Lib;
+=head1 SYNOPSIS
+
+B<dh_elpa> [S<I<debhelper options>>] [S<I<pkg-file>>]
+
+=head1 DESCRIPTION
+
+B<dh_elpa> is a debhelper program that is responsible for installing
+elpa style emacs lisp packages into package build directories.
+
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.elpa
+
+List of files to be installed into I<package> as an elpa package.
+
+=back
+
+=cut
+
init();
sub doit_quietly {
@@ -87,3 +114,18 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
qw{-f package-initialize -l dh-elpa.el},
qw{-f dhelpa-batch-install-file}, "$tmp/$elpadir", $pkg_file);
}
+
+=head1 EXAMPLES
+
+Here is an example of using the helper in a dh(1) style debian/rules
+
+=over 4
+
+override_dh_install:
+ dh_install
+ dh_elpa
+
+=back
+
+=cut
+