summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAge
* use --quick (-Q) for batch-compilation.David Bremner2018-01-03
| | | | | This tries to avoid breakage caused by the local admin customizing the site configuration for emacs.
* Update changelogNicholas D Steeves2017-08-23
|
* Remove work-around because s-el and dash-el have been elpafiedNicholas D Steeves2017-08-23
|
* Declare fast forward from 1.10debian/1.11archive/debian/1.11David Bremner2017-08-04
|\ | | | | | | [dgit --overwrite]
| * Record dh-elpa (1.10) in archive suite sidDavid Bremner2017-08-03
| |\
| | * dh-elpa (1.10) unstable; urgency=mediumDavid Bremner2017-08-03
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | [ Sean Whitton ] * Add dh-elpa-Version: field to binary package control files. This tracks the dh-elpa version used to build the package, to make it possible to find packages that need rebuilding against newer dh-elpa. [ David Bremner ] * Treat 'emacs' as a first class flavour, anticipating Debian emacs packages using that in place of 'emacsNN'. * Fix reporting of ignored flavors on removal (cosmetic change). * Replace '2' in generated emacsen-common compat file [dgit import package dh-elpa 1.10]
* | 1.11: disable dh-elpa-VersionDavid Bremner2017-08-04
| |
* | finalize changelog for 1.10David Bremner2017-08-03
| |
* | make contents of compat file match emacs policyDavid Bremner2017-08-03
| |
* | note remove script fix in changelogDavid Bremner2017-08-03
| |
* | spell FLAVOR consistentlyDavid Bremner2017-08-03
| | | | | | | | Sadly changing to american spelling is the most minimal change.
* | update changelog for maintscripts changesDavid Bremner2017-08-02
| |
* | maint-scripts: treat 'emacs' as a first class flavourDavid Bremner2017-08-02
| | | | | | | | | | The idea is that we will (eventually) collapse the emacsNN flavours into emacs.
* | add dh-elpa-Version: binary package fieldSean Whitton2017-08-02
|/ | | | | | | | | | There is a debhelper mechanism for dh_* tools to embed their versions in generated maintscripts, but our emacsen-common maintscripts are not true maintscripts, so we can't use that mechanism. Using a binary package field makes it possible for us to find packages that need rebuilding without looking inside the contents of any binary packages.
* release 1.9debian/1.9archive/debian/1.9Sean Whitton2017-08-02
|
* bump debhelper compatSean Whitton2017-08-02
|
* drop emacs24 depsSean Whitton2017-08-02
|
* upload 1.8 to unstabledebian/1.8archive/debian/1.8Sean Whitton2017-07-08
|
* bump std-verSean Whitton2017-07-08
|
* drop Built-Using everywhereSean Whitton2017-07-08
|
* fix ordering of copyright stanzasSean Whitton2017-07-08
| | | | See the spec: more specific comes after less specific.
* typoSean Whitton2017-07-08
|
* relicense maintainer scripts under CC0David Bremner2017-07-07
| | | | | | | | Some notes - I follow debhelper in not embedding license info in every snippet - embedding the entire CC0 license in d/copyright is a bit meh, but it's the same number of bytes as a seperate file
* Declare fast forward from 1.6debian/1.7archive/debian/1.7Sean Whitton2017-06-18
|\ | | | | | | [dgit --overwrite]
| * Record dh-elpa (1.6) in archive suite sidDavid Bremner2017-01-08
| |\
| | * dh-elpa (1.6) unstable; urgency=mediumDavid Bremner2017-01-08
| | | | | | | | | | | | * Add an "exit 0" to xemacs case of remove script (Closes: #850036). [dgit import package dh-elpa 1.6]
* | release 1.7 to unstableSean Whitton2017-06-18
| |
* | tweak changelogSean Whitton2017-06-18
| |
* | s, dash and yasnippet now packaged within elpa-*Sean Whitton2017-06-16
| |
* | manpage grammar fixSean Whitton2017-01-27
| |
* | finish implementing ignoring ERT tests in .gitSean Whitton2017-01-10
| |
* | changelog: bump dateDavid Bremner2017-01-08
| |
* | start changelog for 1.6David Bremner2017-01-04
| |
* | maintscripts: add exit 0 for skipping xemacsDavid Bremner2017-01-04
|/
* releasedebian/1.5archive/debian/1.5Sean Whitton2017-01-01
|
* high urgencySean Whitton2017-01-01
| | | | | | Regression since 1.4: packages that are rebuilt could lose their deps on let-alist and seq. These two packages are built-in as of emacs25, which dh-elpa 1.4 depends on.
* add separately-packaged built-in packages to ${elpa:Depends}Sean Whitton2017-01-01
|
* Declare fast forward from 1.3archive/debian/1.4Sean Whitton2016-12-19
|\ | | | | | | [dgit --overwrite]
| * dh-elpa (1.3) unstable; urgency=mediumSean Whitton2016-09-07
| | | | | | | | * Fix version comparison in elpa.pm. Quote "0.90" so that the trailing 0 is not lost. * Override debian-watch-file-in-native-package. [dgit import package dh-elpa 1.3]
* release 1.4Sean Whitton2016-12-19
|
* dh_elpa_test: ignore .gitSean Whitton2016-12-11
|
* tweak changelogSean Whitton2016-12-04
|
* missing commaSean Whitton2016-12-04
|
* update build-dep for emacs25Sean Whitton2016-12-04
|
* update depedency for emacs25Sean Whitton2016-12-04
|
* note about disabling dh_auto_test overrideSean Whitton2016-11-24
|
* add note about allow-stderrSean Whitton2016-10-01
|
* release 1.3Sean Whitton2016-09-06
|
* override debian-watch-file-in-native-packageSean Whitton2016-09-06
|
* fix version comparison in elpa.pmSean Whitton2016-09-06
| | | | | The string representation of 0.90 is "0.9" which is a lower version than 0.77 (the version in jessie which the comparison is meant to exclude).