summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-04-01 18:55:50 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-04-01 18:55:50 -0700
commit72f4653103fb50b43fb7bcc34d246a2887dea9bd (patch)
tree34d3dca2a0b79424033ba37105ac7a8c1f73e15a
parent12cf806b3240008ee7b18680f36a7ad7cd708e64 (diff)
more control file fields
-rwxr-xr-xdh-make-elpa30
1 files changed, 22 insertions, 8 deletions
diff --git a/dh-make-elpa b/dh-make-elpa
index a639e48..120e834 100755
--- a/dh-make-elpa
+++ b/dh-make-elpa
@@ -4,6 +4,7 @@ use strict;
use warnings;
our $VERSION = '0.1.0';
+our $debstdversion = '3.9.7';
use Array::Utils qw{array_minus};
use Cwd;
@@ -79,6 +80,9 @@ initial_sanity_check();
# check for command line arg
our $pkg_emacsen = grep { $_ eq '--pkg-emacsen' } @ARGV;
+# guess
+my $pkgname = basename(cwd());
+
# --- debian/
mkdir "debian";
@@ -150,27 +154,37 @@ if ( -f "debian/control" )
$control->read("debian/control");
}
-$control->source->Source = basename(cwd());
-$control->source->Section = "lisp";
-my $user = "$ENV{'DEBNAME'} <$ENV{'DEBEMAIL'}>";
+$control->source->Source($pkgname);
+$control->source->Section("lisp");
+$control->source->Priority("optional");
+$control->source->Standards_Version($debstdversion);
+my $user = "$ENV{'DEBFULLNAME'} <$ENV{'DEBEMAIL'}>";
if ($pkg_emacsen)
{
- $control->source->Maintainer = "Debian Emacs addons team <pkg-emacsen-addons\@lists.alioth.debian.org>";
+ $control->source->Maintainer("Debian Emacs addons team <pkg-emacsen-addons\@lists.alioth.debian.org>");
unless ($control->source->Uploaders =~ /$user/)
{
- if ($control->source->Uploaders == "")
+ if ($control->source->Uploaders =~ /^$/)
{
- $control->source->Uploaders = $user;
+ $control->source->Uploaders($user);
}
else
{
- $control->source->Uploaders = $control->source->Uploaders . ", $user"
+ $control->source->Uploaders($control->source->Uploaders . ", $user");
}
}
+ $control->source->Vcs_Git(
+ sprintf( "https://anonscm.debian.org/git/pkg-emacsen/pkg/%s.git",
+ $pkgname )
+ );
+ $control->source->Vcs_Browser(
+ sprintf( "https://anonscm.debian.org/cgit/pkg-emacsen/pkg/%s.git",
+ $pkgname )
+ );
}
else
{
- $control->source->Maintainer = $user;
+ $control->source->Maintainer($user);
}
$control->write("debian/control");