summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-04-02 09:07:07 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-04-02 09:07:07 -0700
commitf850803cb571d421cd6d250fe20481f27125f3c8 (patch)
tree38e917bbcbd1c2d481f68f45806bebe5149389d3
parent36255ab5abcc0754576fe0c47ce7f16ee06c7680 (diff)
write & install a manpage for dh-make-elpa
-rw-r--r--debian/manpages1
-rwxr-xr-xdebian/rules3
-rwxr-xr-xdh-make-elpa64
3 files changed, 68 insertions, 0 deletions
diff --git a/debian/manpages b/debian/manpages
new file mode 100644
index 0000000..969cf8f
--- /dev/null
+++ b/debian/manpages
@@ -0,0 +1 @@
+dh-make-elpa.1
diff --git a/debian/rules b/debian/rules
index 4f189d8..fc42a72 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,5 +5,8 @@ DESTDIR=$(CURDIR)/debian/tmp
%:
dh $@
+override_dh_auto_build:
+ pod2man dh-make-elpa > dh-make-elpa.1
+
override_dh_auto_install:
install -m 755 -D dh-make-elpa $(DESTDIR)/usr/bin/dh-make-elpa
diff --git a/dh-make-elpa b/dh-make-elpa
index 120e834..342a4c7 100755
--- a/dh-make-elpa
+++ b/dh-make-elpa
@@ -1,5 +1,11 @@
#!/usr/bin/perl
+=head1 NAME
+
+dh-make-elpa - helper for creating Debian packages from ELPA packages
+
+=cut
+
use strict;
use warnings;
@@ -85,6 +91,7 @@ my $pkgname = basename(cwd());
# --- debian/
+# TODO fail if dir already exists
mkdir "debian";
# --- debian/compat
@@ -195,3 +202,60 @@ Warning -- dh-make-elpa is an experimental script that performs a lot
of guesswork. You should throughly verify the contents of the debian/
directory before uploading
EOF
+
+__END__
+
+=head1 SYNOPSIS
+
+=over
+
+=item dh-make-elpa [--pkg-emacsen] [make]
+
+=back
+
+=head1 DESCRIPTION
+
+B<dh-make-elpa> will try to create the files required to build a
+Debian source package from an unpacked GNU Emacs ELPA package.
+
+B<dh-make-elpa> is an experimental script that performs a lot of
+guesswork. You should throughly verify the contents of the debian/
+directory before uploading
+
+=head2 COMMANDS
+
+=over
+
+=item make
+
+Default command if no command is given. Creates debianisation from
+scratch. Fails with an error if F<debian/> directory already
+exists.
+
+=back
+
+=head2 OPTIONS
+
+=over
+
+=item B<--pkg-emacsen>
+
+Sets C<Maintainer>, C<Uploaders>, C<Vcs-Git> and C<Vcs-Browser> fields
+in F<debian/control> according to the Team's conventions.
+
+This option is useful when preparing a package for the Debian Emacs
+Addon Packaging Team L<https://pkg-emacsen.alioth.debian.org>.
+
+=back
+
+=cut
+
+=head1 AUTHOR
+
+Written and maintained by Sean Whitton <spwhitton@spwhitton.name>.
+
+A great deal of the library code used by B<dh-make-elpa>, and its
+object-oriented structure, comes from dh-make-perl(1), written and
+maintained by the Debian Perl Group.
+
+=cut