summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rw-r--r--lib/DhMakeELPA/Command/make.pm2
2 files changed, 3 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 1d1f1e7..94d9455 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,7 @@ dh-make-elpa (0.5.0) UNRELEASED; urgency=medium
* Add --version option.
* Output useful info when we can't generate d/watch & d/docs.
Thanks to Lev Lamberov for the suggestion.
+ * Fix exiting non-zero after successful run.
-- Sean Whitton <spwhitton@spwhitton.name> Sat, 10 Sep 2016 08:56:40 -0700
diff --git a/lib/DhMakeELPA/Command/make.pm b/lib/DhMakeELPA/Command/make.pm
index 59393f7..23587b7 100644
--- a/lib/DhMakeELPA/Command/make.pm
+++ b/lib/DhMakeELPA/Command/make.pm
@@ -40,6 +40,8 @@ sub execute {
$self->create_gbp_conf() if $self->cfg->pkg_emacsen;
$self->output_caveat();
+
+ return(0);
}
sub create_control {