summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames McCoy <jamessan@debian.org>2019-01-08 00:58:18 -0500
committerJames McCoy <jamessan@debian.org>2019-01-08 01:00:35 -0500
commit09c86441074491f497a66e4f76b95c86f7b63e5d (patch)
treea56554015af1d83a73beef62dec2f0b3dbadf5db
parentdc297e19b36e7385b649eb7f02b2ddc8f9554edb (diff)
Add the vim_addon dh sequence
Signed-off-by: James McCoy <jamessan@debian.org>
-rw-r--r--debian/control3
-rw-r--r--debian/install1
-rwxr-xr-xdh_vim-addon2
-rw-r--r--vim_addon.pm9
4 files changed, 13 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 37cec30..beba0f6 100644
--- a/debian/control
+++ b/debian/control
@@ -24,4 +24,5 @@ Description: debhelper addon to help package Vim/Neovim addons
respective "packpath" for the supported editors as well as building help tags
for the addon's documentation, if any exists.
.
- A debhelper sequencer is also provided for use with dh rules files.
+ A debhelper sequencer, vim_addon, is also provided for use with dh rules
+ files.
diff --git a/debian/install b/debian/install
index 85bb5b6..f59ea3d 100644
--- a/debian/install
+++ b/debian/install
@@ -1 +1,2 @@
dh_vim-addon usr/bin
+vim_addon.pm usr/share/perl5/Debian/Debhelper/Sequence
diff --git a/dh_vim-addon b/dh_vim-addon
index 2cbff8b..f6e5f19 100755
--- a/dh_vim-addon
+++ b/dh_vim-addon
@@ -96,7 +96,7 @@ compatible with Vim and Neovim. The F<debian/rules> is:
#!/usr/bin/make -f
%:
- dh $@ --with vim-addon
+ dh $@ --with vim_addon
=back
diff --git a/vim_addon.pm b/vim_addon.pm
new file mode 100644
index 0000000..17c074b
--- /dev/null
+++ b/vim_addon.pm
@@ -0,0 +1,9 @@
+#!/usr/bin/perl
+
+use strict;
+use warnings;
+use Debian::Debhelper::Dh_Lib;
+
+insert_after('dh_install', 'dh_vim-addon');
+
+1;