summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Guriev <guriev-ns@ya.ru>2019-06-24 22:08:03 +0300
committerNicholas Guriev <guriev-ns@ya.ru>2019-06-24 22:08:03 +0300
commit04045fdddb750991fe6a0842f427ac0ff047398f (patch)
tree9df1dbe5f73924f18e216166417645a5c7644f8c
parent3486402d66fdf68f56f6f54c35245ac812369829 (diff)
Import dhelp v0.6.25 from source repository
-rw-r--r--debian/changelog15
-rw-r--r--debian/control2
-rw-r--r--scripts/conv-pstotext2
-rwxr-xr-xsrc/dsearch6
4 files changed, 20 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 66e5cd6..2c2252e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,18 @@
+dhelp (0.6.25) unstable; urgency=medium
+
+ * QA upload.
+
+ [ Till Kamppeter ]
+ * Replaced the call of pstotext by ps2txt as pstotext upstream
+ is unmaintained for years and stopped working with Ghostscript whereas
+ ps2txt is part of ghostscript. (Closes: #895543)
+
+ [ Iain Lane ]
+ * Add a direct dependency on ghostscript for the above, and remove pstotext
+ as it is no longer used.
+
+ -- Iain Lane <laney@debian.org> Tue, 17 Apr 2018 10:56:58 +0100
+
dhelp (0.6.24) unstable; urgency=medium
* QA upload.
diff --git a/debian/control b/debian/control
index 04fa45e..aebe8b1 100644
--- a/debian/control
+++ b/debian/control
@@ -10,6 +10,7 @@ VCS-Browser: https://anonscm.debian.org/cgit/collab-maint/dhelp.git
Package: dhelp
Depends:
doc-base,
+ ghostscript,
libcgi-pm-perl,
libdata-page-perl,
libhtml-parser-perl,
@@ -17,7 +18,6 @@ Depends:
libtemplate-perl,
liburi-perl,
poppler-utils,
- pstotext,
ruby | ruby-interpreter,
ruby-debian,
ruby-gettext,
diff --git a/scripts/conv-pstotext b/scripts/conv-pstotext
index 6a4b136..6a93b2b 100644
--- a/scripts/conv-pstotext
+++ b/scripts/conv-pstotext
@@ -6,7 +6,7 @@
#
# $1 = Input file, $2 = Output file
-2>/dev/null pstotext -output "${2}" "${1}"
+2>/dev/null ps2txt "${1}" "${2}"
EXITVAL=$?
if [ ${EXITVAL} -ne 0 ]; then
echo "Error converting file: ${1}"
diff --git a/src/dsearch b/src/dsearch
index d4b0217..0bf5b3e 100755
--- a/src/dsearch
+++ b/src/dsearch
@@ -148,17 +148,17 @@ sub get_text {
$text = `/usr/bin/pdftotext "$file" -`;
}
else {
- # pstotext is a dependency, so this should never fail, but we
+ # ghostscript is a dependency, so ps2txt should never fail, but we
# recommend the user to install xpdf-utils instead, to get
# pdftotext (better extraction quality and much faster)
- $text = file_to_text("/usr/bin/pstotext '$file'", "PDF", "xpdf-utils");
+ $text = file_to_text("/usr/bin/ps2txt '$file'", "PDF", "xpdf-utils");
}
}
elsif ($ext =~ /dvi/) {
$text = file_to_text("/usr/bin/catdvi '$file'", "DVI", "catdvi");
}
elsif ($ext =~ /ps/) {
- $text = file_to_text("/usr/bin/pstotext '$file'", "Postscript", "pstotext");
+ $text = file_to_text("/usr/bin/ps2txt '$file'", "Postscript", "ghostscript");
}
else {
open F, $file;