summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2019-01-10 21:57:14 -0500
committerAaron M. Ucko <ucko@debian.org>2019-01-10 22:08:07 -0500
commitc70efc1614cb627b4a4d4e68165f106d6d6d21d4 (patch)
tree69a4f8183c2a6f8016204d5b802f5dadadfc55f5
parentaea618a3dd1b146b38ce4d1991e474cd682129a9 (diff)
Rework packaging in terms of dh-elpa.
There's little benefit in keeping formal XEmacs support when XEmacs already bundles a version. - debian/control: + Build-depend on dh-elpa. + Rename the main binary package to elpa-dictionary (but leave the source package name as is, at least for now.) + Add a formal dependency on ${elpa:Depends}; relegate emacs to Recommends and Enhances. + Turn dictionary-el into a transitional dummy package. - debian/dictionary-pkg.el: New, based on the generated version but with (internal) dependencies commented out. - debian/{dirs,emacsen-*}: Removed, no longer needed. - debian/elpa-dictionary.elpa: New, listing files to install. - debian/rules: Replace with a dh-elpa oneliner.
-rw-r--r--debian/.gitignore1
-rw-r--r--debian/changelog16
-rw-r--r--debian/control21
-rw-r--r--debian/dictionary-pkg.el4
-rw-r--r--debian/dirs1
-rw-r--r--debian/elpa-dictionary.elpa4
-rw-r--r--debian/emacsen-compat1
-rw-r--r--debian/emacsen-install45
-rw-r--r--debian/emacsen-remove15
-rw-r--r--debian/emacsen-startup18
-rwxr-xr-xdebian/rules10
11 files changed, 40 insertions, 96 deletions
diff --git a/debian/.gitignore b/debian/.gitignore
index 17fc026..2e8650b 100644
--- a/debian/.gitignore
+++ b/debian/.gitignore
@@ -1,4 +1,5 @@
*.debhelper*
*.substvars
dictionary-el
+elpa-dictionary
files
diff --git a/debian/changelog b/debian/changelog
index 0bcab86..d091ab5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,11 +4,25 @@ dictionary-el (1.10+git20190107-1) UNRELEASED; urgency=medium
* New upstream snapshot, incorporating most previous outstanding Debian
changes and adding among other things support for custom definition
body faces, preferably variable-width. (Closes: #864644.)
+ * Rework packaging in terms of dh-elpa. (There's little benefit in
+ keeping formal XEmacs support when XEmacs already bundles a version.)
+ - debian/control:
+ + Build-depend on dh-elpa.
+ + Rename the main binary package to elpa-dictionary (but leave the
+ source package name as is, at least for now.)
+ + Add a formal dependency on ${elpa:Depends}; relegate emacs to
+ Recommends and Enhances.
+ + Turn dictionary-el into a transitional dummy package.
+ - debian/dictionary-pkg.el: New, based on the generated version but
+ with (internal) dependencies commented out.
+ - debian/{dirs,emacsen-*}: Removed, no longer needed.
+ - debian/elpa-dictionary.elpa: New, listing files to install.
+ - debian/rules: Replace with a dh-elpa oneliner.
* debian/copyright: Extend upstream copyright through 2014. (The only
subsequent upstream change was merging a small patch contributed by a
third party, and as such doesn't count.)
- -- Aaron M. Ucko <ucko@debian.org> Thu, 10 Jan 2019 21:55:01 -0500
+ -- Aaron M. Ucko <ucko@debian.org> Thu, 10 Jan 2019 21:57:12 -0500
dictionary-el (1.10-3) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index 33b82e3..696700b 100644
--- a/debian/control
+++ b/debian/control
@@ -2,19 +2,28 @@ Source: dictionary-el
Maintainer: Aaron M. Ucko <ucko@debian.org>
Section: lisp
Priority: optional
-Build-Depends: debhelper (>= 9)
+Build-Depends: debhelper (>= 9),
+ dh-elpa
Standards-Version: 3.9.8
Vcs-Browser: https://anonscm.debian.org/cgit/users/ucko/dictionary-el.git
Vcs-Git: https://anonscm.debian.org/git/users/ucko/dictionary-el.git
Homepage: http://www.myrkr.in-berlin.de/dictionary/
-Package: dictionary-el
+Package: elpa-dictionary
Architecture: all
-Depends: emacs | emacsen,
- emacsen-common (>= 2.0.8),
+Depends: ${elpa:Depends},
${misc:Depends}
+Recommends: emacs
+Enhances: emacs
Provides: dict-client
Description: dictionary client for Emacs
- dictionary-el is a DICT (RFC 2229) client for (X)Emacs, with support
+ elpa-dictionary is a DICT (RFC 2229) client for Emacs, with support
for brace-delimited cross references and UTF-8-encoded entries.
- Note that XEmacs bundles a slightly older version of this package.
+
+Package: dictionary-el
+Architecture: all
+Section: oldlibs
+Depends: elpa-dictionary,
+ ${misc:Depends}
+Description: transitional dummy package, dictionary-el to elpa-dictionary
+ This dummy package may be safely removed.
diff --git a/debian/dictionary-pkg.el b/debian/dictionary-pkg.el
new file mode 100644
index 0000000..07f86f5
--- /dev/null
+++ b/debian/dictionary-pkg.el
@@ -0,0 +1,4 @@
+;;; -*- no-byte-compile: t -*-
+(define-package "dictionary" "1.10" "Client for rfc2229 dictionary servers"
+ ; '((connection "1.10") (link "1.10"))
+ )
diff --git a/debian/dirs b/debian/dirs
deleted file mode 100644
index 005c7e5..0000000
--- a/debian/dirs
+++ /dev/null
@@ -1 +0,0 @@
-usr/share/emacs/site-lisp/dictionary-el
diff --git a/debian/elpa-dictionary.elpa b/debian/elpa-dictionary.elpa
new file mode 100644
index 0000000..a034165
--- /dev/null
+++ b/debian/elpa-dictionary.elpa
@@ -0,0 +1,4 @@
+connection.el
+dictionary.el
+link.el
+debian/dictionary-pkg.el
diff --git a/debian/emacsen-compat b/debian/emacsen-compat
deleted file mode 100644
index 573541a..0000000
--- a/debian/emacsen-compat
+++ /dev/null
@@ -1 +0,0 @@
-0
diff --git a/debian/emacsen-install b/debian/emacsen-install
deleted file mode 100644
index b082925..0000000
--- a/debian/emacsen-install
+++ /dev/null
@@ -1,45 +0,0 @@
-#! /bin/sh -e
-# /usr/lib/emacsen-common/packages/install/dictionary-el
-
-# Written by Jim Van Zandt <jrv@vanzandt.mv.com>, borrowing heavily
-# from the install scripts for gettext by Santiago Vila
-# <sanvila@ctv.es> and octave by Dirk Eddelbuettel <edd@debian.org>.
-
-FLAVOR=$1
-PACKAGE=dictionary-el
-
-if [ ${FLAVOR} = emacs ]; then exit 0; fi
-
-echo install/${PACKAGE}: Handling install for emacsen flavor ${FLAVOR}
-
-FLAVORTEST=`echo $FLAVOR | cut -c-6`
-if [ ${FLAVORTEST} = xemacs ] ; then
- SITEFLAG="-no-site-file"
-else
- SITEFLAG="--no-site-file"
-fi
-FLAGS="${SITEFLAG} -q -batch -l path.el -f batch-byte-compile"
-
-ELDIR=/usr/share/emacs/site-lisp/${PACKAGE}
-ELCDIR=/usr/share/${FLAVOR}/site-lisp/${PACKAGE}
-
-## Install-info-altdir does not actually exist.
-## Maybe somebody will write it.
-#if test -x /usr/sbin/install-info-altdir; then
-# echo install/${PACKAGE}: install Info links for ${FLAVOR}
-# install-info-altdir --quiet --section "" "" --dirname=${FLAVOR} /usr/info/${PACKAGE}.info.gz
-#fi
-
-install -m 755 -d ${ELCDIR}
-cd ${ELCDIR}
-rm -f *.el
-ln -s ${ELDIR}/*.el .
-FILES=`echo *.el`
-
-cat << EOF > path.el
-(setq load-path (cons "." load-path) byte-compile-warnings nil)
-EOF
-${FLAVOR} ${FLAGS} ${FILES}
-rm -f path.el # *.el
-
-exit 0
diff --git a/debian/emacsen-remove b/debian/emacsen-remove
deleted file mode 100644
index 6e30b79..0000000
--- a/debian/emacsen-remove
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh -e
-# /usr/lib/emacsen-common/packages/remove/dictionary-el
-
-FLAVOR=$1
-PACKAGE=dictionary-el
-
-if [ ${FLAVOR} != emacs ]; then
-# if test -x /usr/sbin/install-info-altdir; then
-# echo remove/${PACKAGE}: removing Info links for ${FLAVOR}
-# install-info-altdir --quiet --remove --dirname=${FLAVOR} /usr/info/dictionary-el.info.gz
-# fi
-
- echo remove/${PACKAGE}: purging byte-compiled files for ${FLAVOR}
- rm -rf /usr/share/${FLAVOR}/site-lisp/${PACKAGE}
-fi
diff --git a/debian/emacsen-startup b/debian/emacsen-startup
deleted file mode 100644
index 4140962..0000000
--- a/debian/emacsen-startup
+++ /dev/null
@@ -1,18 +0,0 @@
-;; -*-emacs-lisp-*-
-;;
-;; Emacs startup file for the Debian GNU/Linux dictionary-el package
-;;
-;; Originally contributed by Nils Naumann <naumann@unileoben.ac.at>
-;; Modified by Dirk Eddelbuettel <edd@debian.org>
-;; Adapted for dh-make by Jim Van Zandt <jrv@vanzandt.mv.com>
-
-;; The dictionary-el package follows the Debian/GNU Linux 'emacsen' policy and
-;; byte-compiles its elisp files for each 'emacs flavor' (emacs19,
-;; xemacs19, emacs20, xemacs20...). The compiled code is then
-;; installed in a subdirectory of the respective site-lisp directory.
-;; We have to add this to the load-path:
-(debian-pkg-add-load-path-item
- (concat "/usr/share/" (symbol-name debian-emacs-flavor)
- "/site-lisp/dictionary-el"))
-(or (load "dictionary-init" t)
- (message "The dictionary-el package appears not to be fully installed."))
diff --git a/debian/rules b/debian/rules
index 233c191..a1e6053 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,11 +1,3 @@
#!/usr/bin/make -f
-instdir=debian/dictionary-el/usr/share/emacs/site-lisp/dictionary-el
-
%:
- dh $@
-
-override_dh_auto_build: ;
-
-override_dh_install:
- install -m644 *.el $(instdir)
- rm $(instdir)/lpath.el
+ dh $@ --with elpa